Heroes of the Storm invisible Cursor


I am quite new to lutris and linux gaming. I tried getting HotS to work and to be fair it is starting and it looks like it is quite responsive, but I am running in the issue that I dont get the cursor to show up in the menu.
In addition as soon as I tab outside the game, the game will be in a teeny tiny window but as soon as I move my mous into the window I will see the ingame cursor. I tried multiple ways to force the game to not start in full screen:
DISPLAYMODE 0 in Battlenet Launcher
I tried virtual Desktop Setting
and I tried to set the winecfg > graphics tab > Automatically capture mouse in fullscreen windows.

But so far nothing worked. I am kinda out of ideas and so far i was not able to find any solution in google.

Some help would be appreciated.

OS: Pop!_OS 22.04 jammy
Arch: x86_64
Kernel: 6.9.3-76060903-generic
Desktop: pop:GNOME
Display Server: x11

Vendor: GenuineIntel
Model: Intel(R) Coreā„¢ i7-8550U CPU @ 1.80GHz
Physical cores: 4
Logical cores: 8

RAM: 7.6 GB
Swap: 11.6 GB

Vendor: Intel
OpenGL Renderer: Mesa Intel(R) UHD Graphics 620 (KBL GT2)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 24.0.3-1pop1~1711635559~22.04~7a9f319
OpenGL Core: 4.6 (Core Profile) Mesa 24.0.3-1pop1~1711635559~22.04~7a9f319
OpenGL ES: OpenGL ES 3.2 Mesa 24.0.3-1pop1~1711635559~22.04~7a9f319
Vulkan Version: 1.3.280
Vulkan Drivers: NVIDIA GeForce MX150 (1.3.277), Intel(R) UHD Graphics 620 (KBL GT2) (1.3.274)