Back to the main site

Heroes of the Storm DXVK freeze at Play screen


#1

Hello,
I’m using Lutris 0.4.19 on Fedora 28 with Wayland. I’ve installed HotS by official Lutris script (https://lutris.net/games/install/8499/view). It works without enabled DXVK on the lowest details, but lags (I know, I have shitty HW for games :wink:

HW: Thinkpad
CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4
GP: Intel® HD Graphics 520 (Skylake GT2)
RAM: 16GB
HDD: SSD

When DXVK is enabled (HUD is visible and vulkaninfo works) listing heroes, lootboxes, setting etc. work fine.
But it freezes in the beginning of play screen animation (I can kill wine in my Gnome3).
After replay loading is done (ran in Watch screen) my computer is completely frozen (I’ve had to use hard reset)

I’ve tried all wine versions, change parameters (WINEESYNC=1; mesa_glthread=False etc.), run HotS directly (exec Support64/HeroesSwitcher_x64.exe -d11) and Workaround for DX11 and 64-bit client (I know it’s a different issue, but maybe it works :wink:

And nothing works.
Please help.


#2

DId you ever get this working I am having the exact same thing with almost identical hardware!


#3

Have you tried using a virtual desktop?