[HELP] Battle.net won't work unless I delete drive_c/programdata/battlenet

I installed the DOX all-in-one version of battlenet but I still can’t manage to open it. I tried both with 3.14 staging and esync, and both DXVK 0.54 and 0.65, but the only way I can manage to make the login windows prop up is by deleting drive_c/programdata/battle.net and Blizzard Entartainement. Next, when I open the actual app, it tells me that “Blizzard agent is asleep” or that “There’s been an error” and that I need to reboot. How can I work around this? I’m on ubuntu 18.04, if that’s any help.

Try deleting onlly “C:\ProgramData\Battle.net\Agent\product.db”, and then start BN again.

Its basically the same as deleting the entire folder, but it could work differently. Ubuntu 18.04 users seem to have the most issues with this, and I don’t have that. So please try it, and give me feedback.

1 Like

There’s no product.db though. Inside /Agent there is only a folder called Agent6326, another folder called Logs, Agent.exe, BlizzardError.exe and BlizzardUninstaller.exe.

Well, then just try to delete the entire folder again. Thats the only fix I have found myself for Blizzard App.

A “killall Agent.exe” in terminal could help aswell according to some people. But that hasn’t worked for me.

And I’m back at square one. I delete the folder, Battlenet opens, then tells me there’s something wrong and you need to reboot, creates the two folders again and won’t boot up again 'till I delete them.

I have never heard that it needs to reboot. But since you are using the All in One - do you have Vulkan installed correctly?

Try the other Blizzard Installer, or better yet, try the installer for the game you want to play first.

I’ve been seeing this issue for a while now. It’s quite possible it started when I upgraded to Linux Mint 19. I’ve just completely trashed all my drives (intentionally :)) and repartitioned and installed LM19 again. I haven’t quite gotten around to installing Lutris or any games yet as I’m restoring all my backed up data at the moment.

Additional to ‘Agent’ being asleep, I started having problems patching any of the Battle.net apps, especially after deleting product.db. Battle.net either failed to find the games again, or it would just sit there ‘waiting for another installation to finish’.

As someone that uses Linux at home and a Mac for work/traval (company supplies hardware) I have run into this issue on both platforms, so I actually think it’s some kind of software bug. I ended up deleting battle.net application entirely on both platforms and reinstalling it (not the game though, just the launcher). At first I also got stuck at “Downloading…”, but after I let it sit for like 20 minutes at 0% it suddenly worked. After the new battle.net client was installed, I haven’t had any issue since on any of the platforms.

There seems to have been a new update again.Hopefully that will fix it. (we hope every time)

@Dox So, I uninstalled the All-In-One (I managed to make it work, but it let me install only one game; all other games it would continue to spin around without ever prompting me to install), and installed the version of the game I wanted to install (HotS). It seems to work for now, I’m downloading the game as we speak.

OT: are there additional dependencies for your SCII installer, Dox? It keeps giving me the “Couldn’t find battlenet.exe” problem despite having all dependencies installed as indicated by the GitHub page you linked. Which is kinda strange. Also, how to set the proverbial PBA_DISABLE:1? Where do I need to put this line? Thanks and sorry for the OT.

I never liked the All in One - I made it because I could…but having nvidia it wasn’t good for me. I might remove it at some point, and pointing back to the individual installers.

And OT: no, no extra dependencies.

Yeah I have issue with battlenet to.

I have reinstalled my system with manjaro (because I test a lot of distro).
Batlenet install is ok, but when I try to install SC2 from battlenet I have the new windows and then I wait, wait and wait but nothing new happen (just that little icon turning in te corner).

I have try enabling or not dxvk but that don’t change anything.

Is there a way to install the game outside battlenet and then “link” the launcher with the installed game ?
Maybe this will help.

I had the same issue, but what worked for me was switching my wine configuration from “Windows 10” to “Windows 2008 R2”. The install button was then no longer greyed out and I was able to install (World of Warcraft in my case).

Interesting that it worked when you changed windows version. Could be coincidence, or it could be a different codepath.

Can someone else that has issues confirm?

Switching the config to 2008 doesn’t work for me. I’m getting the agent being asleep issue in the All-in-One and individual installers.


I’ve used the installer and I got the blizzard app running.

However, I can’t get past the “agent went to sleep” error, even with deleting the folders in ProgramData.

Any suggestion how should I enable some kind of debug window or a log where I could look what actually happens?

Basically, the Blizzard app is stuck in a loop, with the “agent went to sleep” and then displaying the “something has crashed error”:

  1. Start it and get the error.
  2. Close it and delete the two folders in ProgramData: “Battle.net” and “Blizzard”
  3. Restart and get the same error.

I can’t make it install any games.

I basically have the same issue reported above here.

Specs: Ubuntu 18.04
Wine staging / esync 3.14 (as indicated by Lutris)
Windows 7 set up in wine configuration
Installed the ms fonts
PBA Disable = 1 in config
I’ve installed on an nvme drive, with around 40GB for home and dual boot with windows 10.

lutris -d in terminal will show debug output.

something has crashed is an error I have never seen. So check the logs, look for errors. (Ignore winemenubuilder error)

agent went to sleep is fixable, until it breaks again, with deleting the ProgramData/Battle.net folder. (So not the Blizzard folder)

Looking through logs, looks like it was having trouble loading Vulkan. Discovered I had inadvertently uninstalled my i686 packages when updating mesa.

I suspect something similar, it cries out it can’t find some vulakn library. Could you please detail the re-installation steps?

Thank you.

Its distro specific, so you should check your distro’s Wiki (most have them, but people don’t always look there, they just google).

For Ubuntu / Arch we have it here: https://github.com/lutris/lutris/wiki/How-to:-DXVK