Hearthstone not working after latest update


I have been using Lutris to play Hearthstone for the last few months. After the recent update from Blizzard, the game closes after being launched (from battle.net) with the error message:

We just ran into a network problem as we were loading up all the cards in your collection. Please relaunch Hearthstone to access your collection and resume your duels!

(see first screenshot)

Screenshots and Debug Info


I tried reproducing the issue with lutris -d (debug mode) however, the game will not launch in that mode. Instead, I get a different error, this time from Lutris: “your limits are not set correctly” with a link to a page, but I wasn’t able to follow those instructions, and this popup does not occur when using Lutris in normal mode. The log above (in the pastebin) thus doesn’t have a record of the real issue, only of the fact that the game won’t launch in debug mode.

What I tried

In the past I have had issues running Hearthstone after an update, but was able to solve them by uninstalling and reinstalling. This doesn’t seem to be working this time.

Also things are kind of confusing when re-installing it, even in a clean directory. Sometimes I am asked for Gecko which is not mentioned in the dependencies, but sometimes I am not asked for Gecko. Sometimes battle dot net is installed, but when installing Hearthstone from battle dot net, the installation hangs near the end.

I have also tried restarting the computer and repeating this process.

Thanks in advance!

P.S. due to “new users are not allowed to include more than 2 links”, I spelled out the “battle dot net” references, hopefully that works.