Guild Wars 2 stuck before install

Hallo.

I wanted to try and play GW2 via Lutris but when I press install nothing happens.
I tried the same thing with another game SWTOR and the install launcher download happend nearly directly so it seems for me that something is wrong with the GW2 launcher download it doesnt even wanted to create the Games and GW2 Folder.

Is there a problem with the installation programs of the cummunity?

1 Like

How about the steam version? -provider Portal you can login in existing account

In the installer replace wine version (proton-ge) by : lutris-7.2-2-x86_64

After posting this I searched about Steam and GW2 and found the -provider Portal inside the commanding line. It worked without any problems.

How do I do this with lutris-7.2-2-x86_64? I have only Lutris 4.1 as an option within Linux Mint’s app store and within Lutris itself I dont see any option for Proton within Wine selection options.

You need to go on GW2 page on lutris website, then on the first intaller select “Fork” in the rightside menu, then confirm “Fork” on the next page. After, on another next page, you need to modify the last line version in the “content” frame by lutris-7.2-2-x86_64 to force the use of this runner during installation. Then click on “Test this installer” below and it will launch this with your installed Lutris app.
You can also “Save draft” to keep it for later, it’s link at your Lutris account and you’ll see it on the Lutris’ GW2 webpage with others installers.

1 Like

This worked for me. Posted the update and submitted to mods. Thanks!