Guild Wars 2 Poor Framerates

Hi all,

I’ve been trying to play Guild Wars 2, and while I can install and load the game, the framerates are awful. I can’t seem to get more than 20 fps at any time.

The main Lutris page for the game says it works flawlessly with ‘minor tweaking’, though it doesn’t say what this tweaking is.

Even on the graphic settings for best performance for the game I only get about 22 fps, and I can’t see why. It’s almost like there’s an invisible limiter somewhere.

I did a fresh install of the game yesterday using the current Esync settings. I’ve made the changes to the limits.conf file as mentioned here but it makes no difference at all.

My PC may not be the ‘ultimate’ gaming machine, but it doesn’t have any problems giving me 60 - 100 fps playing WoW with Lutris.

So what am I missing?

I’m not playing it anymore, but I remember there is a graphic setting, where you could adjust subsampling (or whatever it is called).

Plainly said: On the highest mode, it would render at a higher resolution than your screen, but scale it down to your screen. This obviously takes a lot of performance. Try finding this setting and set it to… dunno, normal or whatever it is called. That was the total FPS eater when I played GW2.

I’ve been playing it the last few days. Using the latest Esync and -autologin -dx9single arguments and just WINEESYNC=1 environment variable.

I have to turn most of the graphic settings down. Get out of the cities and do your testing out in the wilds. Big cities make mine get a bit slow, especially Amnoon.

I run it in a window, but its a big bigger than 1440p resolution window size. I’ve got a big 4K monitor and it struggles a bit too much at fullscreen.

Ah, “Render Sampling” I guess was the option I was looking for, and you set it to “Native”, which is correct.

Mh, have you tried to run it on DX11 (if this is possible) with DXVK?

Other than that, bear in mind that I haven’t played this game for a long time, so we better wait for a GW2 guru here :slight_smile:

Thanks both. Using CT’s settings I’ve got slightly better fps. Nowhere near the 70+, but somewhere between 40 and 50 on my GTX970. Still seems a bit poor, but at least it’s playable :slight_smile:

I believe GW2 is still DX9 only. I did try DXVK, but nothing was different, the DXVK hud didn’t even appear.

I’m running an RX580 with amdgpu driver on a Ryzen 2600x for reference. Manjaro.

I’ve had the game just crash and close a few times, mostly while getting around Amnoon. I’ve also had a good number of several hour long sessions too. I consider it quite playable.

One last thought, if your game isn’t fully downloaded, you know, you are clicking on play before the download completes, then it may be downloading in the background and slowing you down. There is an option in-game for background downloading, mine is set to ‘Idle’.

You’d need to use VK9 for DX9. and there’s no HUD for it.

Ah cool. I’ll give it a crack.

Edit - Couldn’t get VK9 to work. When I change d3d9.dll to native, the launcher just freezes on its self update check.

Ya I had a similar experience myself. Didn’t have much time to play with it. I couldn’t get it to build either. Kept getting error’s. It might be too early stage of development, or I simply have no idea what I’m doing.