Guild Wars 2, Mouse glitch and login bug

I’m using Fedora 28, KDE, Esync enabled, Nvidia driver 396.45, GTX960, intel i5 4460, Lutris
When i move the camera with the right click button the cursor goes in the top left corner of the display, which makes the game unplayable.
Also when i run the game, in the login section, the button “play” it’s unclickable: i must boot the game a second time and it becomes clickable.

I’ve almost identical setup:
Fedora 28 vanilla (Gnome 3), esync wine, GTX660 with latest driver from fusion repo, lutris on intel platform too.

I’ve not experienced this bug. Maybe a KDE issue or some hardware (the mouse?).

I tried to run the game on gnome and the issue seems solved.
I do not want to change DE, does someone know how to solve this problem? i have no idea about how debug this issue.

My advice is to get in touch with the devs: in your case it seems it should be the bug tracker for KDE.
Here it is:

i’ve tried to change mouse and the problem disappears!
The problem seems to be with my Cooler Master Xornet: if i use a simple logitech m175 the bug is solved.
Do you know what could be a fix? xD

Possibly, you have pin pointed the culprit: the mouse and how KDE deals with it. IMHO now you need a more precise identification of your mouse. The reason for this is many vendors use the same hardware using different names or the same name with different hardware.

The command line is you friend, type:
$ lsusb
You’ll get a unique identifier for your mouse, e.g. mine is:
$ lsusb
Bus 003 Device 004: ID 062a:4102 MosArt Semiconductor Corp.

The relevant part is after “ID”: 062a:4102
This number is what the devs use, and is useful to run a search through your preferred search the web engine. You might find your issue in some bug already reported and maybe a workaround/fix for it.
Like this one:
Unfortunately, there is no answer yet.
You might have more luck using the number, because it is what you may find in the code itself.