Back to the main site

[Guild Wars 2] Everything freezes

I tried both 32bit and 64bit versions of GW2 from Lutris site and it downloads fine but when i run it and when its past the initial download my whole laptop freezes and i can only move my mouse.

I can’t click out or quit the game and i need to restart it every time.

I am using Ubuntu 17.04 64bit

I can confirm issues with GW2 on Fedora 28 as well.

The install goes extremely smooth, no issues, but when you launch into the game the FPS is always around 1 - 20 max. I’ve messed around with the graphical settings for it but it doesn’t appear to be a graphical problem.

Also after running the game for around 15 minutes it completely froze my entire computer and forced a hard reset.

I’ve seen this issue as well on Arch Linux and Ubuntu but only under Gnome desktop or KDE Plasma when compositing is enabled. It seems to work perfectly on light-weight window managers/desktop environments like Xfce, Mate, fluxbox, openbox, LXDE, etc. I’m using a Radeon R9 290 with the amdgpu driver.