Back to the main site

Guild Wars 2 error when using DXVK above 1.4.6

I get this error when trying to launch Guild wars 2 with any DXVK version above 1.4.6.

Screenshot from 2021-04-29 15-17-46

1.4.6 works but it’s not very good performance wise (i think). Is there a way to try other DXVK versions? Am i missing something that i need to install? Or is the game just like this?

Also, i’ve seen that DXVK async can improve performance, but that is apprently abandoned now i’m told? Is there a way to improve performance with something simmilar? Some lutris settings that i need to change?

I’m using theese settings:
Wine version: lutris-5.7-11-x86_64
DXVK version: v1.4.6
Enable Esync - yes
Enable DXVK/VKD3D - yes

That’s the only combination that works for me, and not very well. Other wine versions prevent login (though whatever, wine wouldn’t affect perfromance like that anyway, would it?), and i can only use this DXVK version. I read that 1.8 has improved perfromance, but i get an error when trying to use any of the installed ones…

Or did i just not install the 1.8 version for some reason? How do i check that?

Thank you for reading!

Hello!

Another GW2 player! :slight_smile:

I play with Lutris Wine version 5.7 as you, (6.0 does not work) and DXVK 1.8, everything runs fine. I’ve only got a little GTX 650 + E3-1220 Xeon in my linux box and I get 50-60fps in open world (old zones) and around 30-40fps for newer maps (HOT, POF) , this with medium ish settings on 1920x1200.

I’m not on my linux box atm, I’ll post my settings shortly.

1 Like

OK, so here are my settings.

For starters, I ran the first installer from the Lutris website https://lutris.net/games/guild-wars-2/

Wine Version -> Lutris-5.7-11-x86_64
Enable DXVK/VKD3D
DXVK Version -> v1.8.1L
Enable ESync
Everything else is set to default.

If you used the installer script I linked above, you should have the following keys / environment variables under ‘System Options’

Key Value
DXVK_HUD 0
DXVK_LOG_LEVEL none
STAGING_SHARED_MEMORY 1
__GL_SHADER_DISK_CACHE_PATH /home//Games/guild-wars-2
__NV_PRIME_RENDER_OFFLOAD 1

Make sure you game media is on a non-NTFS partition. What GPU do you have? Some older integrated Intel solutions don’t work well with DXVK.

1 Like

Hello! :slight_smile:

I’m having a wild ride trying to get GW2 to work in Linux…

I figured out the part of the problem.
I switched to PopOS and apparently Ubuntu (what i was using before) and Pop were using Radeon drivers instead of AMDGPU drivers. In Pop, i enabled AMDGPU and now i think they work, the whole system seems more smooth and responsive.

I ended up installing GW2 from a script i found on the official forums instead of Lutris, and this wroked for a whole 1 day before it broke again…

Here’s my entire wild ride detailed in the thread on the official forums if you want to read through it:

And now the game is back to running at 5FPS with no explanation.
I think it’s not using DXVK at all or using software renderer or something.

But… It’s not a lutris installation now. So i think - now that i enabled AMDGPU, i should go back to lutris and install GW2 with it, i think it will use the correct driver now.

Because what lutris was giving me, the errors - i think were caused by the Radeon driver. The same happened with the custom script, same “unable to initialize 3D” and “unable to install” messages that went away after i switched to AMDGPU driver instead of Radeon.

Idk, wish me luck, i’ll report here after i install it with Lutris again to tell if it worked or not.

Ok, i installed the game via Lutris.
Using wine 5.7-11 and DXVK v1.8.1L and i get 3 FPS in game.
I also can’t get DXVK HUD to appear, i set it to “full” (no quotes), and nothing which leads me to believe it’s not using DXVK or even my AMDGPU driver at all…
It looks like what would happen if i tried to run the game on Windows using the software renderer.

I’m losing my mind here, i don’t want to go back to WIndows. :cry:

Here’s the log file:

Running /home/vepar/.local/share/lutris/runners/wine/lutris-5.7-11-x86_64/bin/wine /home/vepar
/Games/guild-wars-2/drive_c/Program Files/Guild Wars 2/GW2-64.exe -autologin
Initial process has started with pid 29542
Start monitoring process.
esync: up and running.
WARNING: radv is not a conformant vulkan implementation, testing use only.
wine: configuration in L"/home/vepar/Games/guild-wars-2" has been updated.
WARNING: radv is not a conformant vulkan implementation, testing use only.
WARNING: radv is not a conformant vulkan implementation, testing use only.
WARNING: radv is not a conformant vulkan implementation, testing use only.
WARNING: radv is not a conformant vulkan implementation, testing use only.
Monitored process exited.
All monitored processes have exited.
Monitored process didn't return an exit code.
Exit with returncode 0

Ok yeah, this isn’t working unfortunately…

I finally made it run with DXVK 1.7.3 instead of the newest one, but that worked for 1 session and after that, all the GW2 audio became distorted…

Not to mention, when it did work, there was some slight but noticable input lag on everything. Very disorienting.

Last thing i tried was using Proton to run it through Lutris, but no luck there either.
It seems that either my hardware isn’t capable of running all the emulation necessary, or isn’t supported the best because it’s not new.

I really wanted this to work because i really wanted to switch to Linux full time, but it’s just not happening right now. I will definitely try again when i inevitably upgrade my hardware.

Til then, back to giving Microsoft my data! :roll_eyes:

Thank you for the help in this matter, and kudos to Lutris team for making such an amazing sotware, i would have given up long ago or probably wouldn’t even be able to run the game once without it lol.

Keep up the good work and i’l see you again one day when i get a new computer! :slightly_smiling_face: