Guild wars 2 does not work

So the game launcher window does not open, nothing visible is happening. clicking “play” on lutris results game’s status switch to running… and the it closes without any notice. Only visible thing telling it has stopped is simply that I can launch the game again from lutris. so here are the files we are asked to provide on support forum…

ty for help ^^

excuse me if I’m breaking the server rules I’m bumping this cos I fixed a link to all those documents. you cant really help me fix the issue without those, can you?
also, please let me know me if the pastebin document expired, and I fix it.

Not much help other than to let you know that I just tried GW2 and it started fine for me. So it isn’t an overall issue from a recent GW2 patch.

Is this a fresh install?

OK, took a gander at the logs and see what I could find and found the following:

Not having Vulkan working would do it. Check the Lutris Vulkan FAQ on how to get Vulkan working:

Continuing this thread since symptoms are same (game can be launched but nothing shows up and it goes back to showing play)

I see following for Vulkan (System infor from Lutris):

OS: Pop!_OS 20.10 groovy
Arch: x86_64
Kernel: 5.11.0-7614-generic
Desktop: pop:GNOME
Display Server: x11

Vendor: GenuineIntel
Model: Intel® Core™ i7-6700K CPU @ 4.00GHz
Physical cores: 4
Logical cores: 8

RAM: 31.2 GB
Swap: 31.6 GB

Vendor: AMD
OpenGL Renderer: Radeon RX Vega (VEGA10, DRM 3.40.0, 5.11.0-7614-generic, LLVM 11.0.0)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.0.0
OpenGL Core: 4.6 (Core Profile) Mesa 21.0.0
OpenGL ES: OpenGL ES 3.2 Mesa 21.0.0
Vulkan: Supported

I deleted game folder altogether and tried installing/launching game even that failed.
I used same launcher for previous year or 2 without any issues (even ArcDPS worked), recently I’m having this issue.
I could launch the game with WINEPREFIX= gw2-64.exe (until I deleted game folder) however this doesn’t have performance tweaks and I seem to be running around 18-20 FPS max.

I should have added this:
How do I debug in this case? At this point I don’t even know what is problem