Back to the main site

Gta2 manager desktop entry bug fixes

I have installed gta2 on my ubuntu 20.04 machine using this. The installation was a success, and I was able to play the game through the lutris client. However, gta2 manager was not accessible through the lutris client, and the desktop entries did not do anything when I clicked on them.

I digged through a bit, and found that the .desktop files for gta executables were located in “/home/username/.local/share/applications/wine/Programs/Rockstar Games/GTA2”. However, the wine executable specified in these desktop entries were “/home/ubuntu/buildbot/runners/wine/lutris-5.6-2-x86_64/bin/wine”, which did not exist. Moreover, the path in which these entries resided did not seem to be supported by gtk-launch command, and hence changes made in these files did not seem to be effective immediately.

I applied the following steps to make the desktop entries work properly:

  1. Change “/home/ubuntu/buildbot/runners/wine/lutris-5.6-2-x86_64/bin/wine” to “/home/username/.local/runners/wine/lutris-5.6-2-x86_64/bin/wine” in “/home/username/.local/share/applications/wine/Programs/Rockstar Games/GTA2/GTA2 Manager.desktop” file exec= line.
  2. Copy the modified .desktop files temporarily to “/home/battal/.local/share/applications”, which is suitable for gtk-launch.
  3. Wait and refresh the application drawer until two entries are seen for gta2 manager in the application drawer. Run the leftmost one among them, just once. Close afterwards.
  4. Remove the copied .desktop entries from “/home/battal/.local/share/applications”, they do not seem to be needed anymore.

After these steps, I was able to make gta2 manager work through the desktop entry in the application drawer.

If there is a way so that this issue could be avoided without such workarounds by modifying the runner script, It would be very nice, but I do not know how. I am new to lutris, and do not know the inner workings of it. So I thought someone knowledgeable could use the fix provided above to have an insight about the issue and possibly fix it.

Sorry for the long post, and thanks in advance.

The Windows installer must have made that .desktop file. I wonder if there’s a way to make a .desktop file that points to Lutris but runs a different executable than the normal one for that game. I know you can click on your game, then click “Run EXE inside wine prefix”. This would be easier than keeping the .desktop file made by a Windows program via Wine up to date.

I see that there’s a --exec option in the lutris --help output. I wonder if you could change your exec= line to lutris gameid --exec path/to/manager.exe