GTA V Social Club launcher crashing

I’ve been trying to get GTA 5 to launch, but each time I launch it with latest stuff, (Wine 3.15 and latest drivers, latest DXVK, etc) the launcher crashes at “Downloading…”. I have tried a few workarounds like -noChunkedDownload and DXVK_CONFIG_FILE=lo/cat/ion/gta_dxvk.conf and even setting xaudio2_7 to native,builtin, but nothing works that I’ve found. If someone could help me with this that’d be great, I really want to play GTA 5 on here so I can abandon windows.

I managed to get the game to work now by reinstalling social club with the GTAV_Setup_Tool.exe by “reinstalling” (it literally did nothing but try to reinstall directx and place a desktop shortcut) to the same directory that i had gta 5 in, then the game would start
THENNN I also had an issue with "Couldn’t find a directx 10 or 11 adapter, so I had to install mesa-vulkan-drivers because for some reason i didn’t already have them and the game started fine.

now the problem I have is the gameplay doesn’t work at all and crashes my entire desktop forcing me to restart restart in order to get back into the desktop cause the game locks up everything. I haven’t found a cause to this yet or anything, and I don’t want to run the game again until I get this fixed cause forcing the computer to restart everytime is probably a bad idea.

K just tried installing game same issue…

rmb on game, winetricks -> select the default wineprefix -> install a font -> corefonts

yeah i have no idea why but it seems its fonts that crash it…