Back to the main site

"graphics card not supported or need latest drivers" [solved]

I’m launching Epic Games Store from Lutris on Solus Plasma, using the latest Nvidia drivers, with a 1060 (6GB) GPU, and getting the error message

There is a problem with your graphics card. Please ensure your card meets the
minimum system requirements and that you have the latest drivers installed.

lutris --submit issuelog here: Ubuntu Pastebin

Terminal output when typing lutris -d into the Konsole is:

2021-10-21 19:36:47,306: Starting Lutris 0.5.9
2021-10-21 19:36:47,352: No cores found
2021-10-21 19:36:50,079: Startup complete
INFO 2021-10-21 19:36:50,085 [startup.check_driver:53]:Using NVIDIA dr
ivers 470.63.01 for x86_64
INFO 2021-10-21 19:36:50,085 [startup.check_driver:57]:GPU: NVIDIA GeF
orce GTX 1060 6GB
INFO 2021-10-21 19:36:50,086 [startup.check_driver:73]:GPU: 10DE:1C03
1028:11D7 (nvidia drivers)
DEBUG 2021-10-21 19:36:50,305 [lutriswindow.update_store:451]:Showing 1
games

Ed: EGS error logs here: Ubuntu Pastebin

Do you have Vulkan installed? I presume that installing the nvidia drivers installs kernel driver, opengl libraries and now vulkan libraries, but I haven’t had one in many years and I can’t say how a distro’s nvidia packages will be (i.e. it could be a separate package)

You could try appending -opengl to the command that launches the epic games store executable in the game options in Lutris to see if it launches for you. After the quotes, in a path with spaces.

Yeah, vulkan is installed, or atleast, attempting to install vulkan via the CLI returned a message saying it’s already installed, idk if there’s something else I might need…

In lutris, under Configure Epic Games Store> Game Options> Arguments it already had
-opengl -SkipBuildPatchPrereq
in the box.

Did you try to run their latest beta driver ? 495.29.05

Trying that, it now won’t launch EGS at all, saying Vulkan isn’t installed…

Ok so just for the lols I installed both the Nvidia-glx-driver and the Nvidia-beta-driver at the same time (I had assumed I should uninstall one before installing the other but, yano, idrk why I think that so I figured shot in the dark, why not both?), and it shows the “vulkan not installed” but then lets me launch and acts the same as when I hadn’t had the beta drivers installed.

lol… jesus, okay, so realizing I can install two sets of drivers side by side made me re-evaluate, and I started going through the many many many different drivers available via the Solus Software center, and waaaaaaay down the list I see “nvidia-glx-32bit-driver” and I’m like “…that’s not included in the nvidia-glx-driver”? So I grab that, and it’s working.

So thanks! :smiley:

Ahh, I just assumed it would default to directx probing and you’d need the Vulkan back end. (I don’t actually have Epic Games Store… I don’t buy their games).

It’s bollocks how distros split packages (though it makes sense for the 32 bit libs here). Last time I had an Nvidia card, I used to just run the Nvidia installer. I build my own kernels so I always had the configured source tree so the nvidia module could build, it would do that, replace the OpenGL libraries and at the end it would ask me if I wanted the 32 bit Nvidia libraries , y or n.

I’m glad you got it sorted.

Yeah, thinking about it it makes sense the 32bit is seperate, but it just didn’t even cross my mind, and after scrolling for a bit it was all like… advanced use drivers, or legacy drivers, so seeing the 32bit way below that was wholly unexpected.