Back to the main site

GOG Login Window Doesn't Appear [Solved]

Edit: Turns out that I had removed the libsecret package by accident. I reinstalled it and now it works again, sorry.

Hello, first time posting here. I’ve been having a problem with Lutris version 0.5.8.4. When ever I try to push the icon to either connect to GOG or Humble Bundle, nothing happens. I recently upgraded my Lutris, but the version prior to this didn’t work either. Here is my basic System Info:

OS: Manjaro Linux x86_64
Kernel: 5.10.49-1-MANJARO
Uptime: 23 hours, 26 mins
Packages: 1233 (pacman)
Shell: bash 5.1.8
Resolution: 1920x1080
DE: Plasma 5.22.3
WM: KWin
Theme: Sweet [Plasma], Sweet [GTK2/3]
Icons: candy-icons [Plasma], candy-icons [GTK2/3]
Terminal: konsole
Terminal Font: Noto Mono 10
CPU: AMD Ryzen 7 2700X (16) @ 3.700GHz
GPU: NVIDIA GeForce RTX 2070 Rev. A
Memory: 6767MiB / 15994MiB

And here is what the terminal shows when I run Lutris and try to click connect:

** (lutris:120366): WARNING **: 14:22:27.057: Failed to load shared library ‘libwebkit2gtk-4.0.so.37’ referenced by the typelib: libsecret-1.so.0: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File “/usr/lib/python3.9/site-packages/lutris/gui/widgets/sidebar.py”, line 169, in on_connect_clicked
self.service.login()
File “/usr/lib/python3.9/site-packages/lutris/services/gog.py”, line 115, in login
dialog = WebConnectDialog(self, parent)
File “/usr/lib/python3.9/site-packages/lutris/gui/dialogs/init.py”, line 356, in init
self.context = WebKit2.WebContext.new()
gi.repository.GLib.Error: g-invoke-error-quark: Could not locate webkit_web_context_new: ‘webkit_web_context_new’: /usr/lib/libjavascriptcoregtk-4.0.so.18: undefined symbol: webkit_web_context_new (1)