GOG import issues. Client can't find game in API

Tried using the GOG integration to import my GOG games. The sign-in seems to work perfectly, but trying to import certain games and the client is silent.

I ran lutris -d and found the error:

DEBUG    2019-11-22 20:26:46,176 [http.get:68]:GET https://lutris.net/api/games
DEBUG    2019-11-22 20:26:46,793 [api.get_game_api_page:134]:No game found for 1458058109

I realize there are a few other topics discussing this issue, but I thought I’d make a bump in case the lutris devs aren’t sure if it’s still a problem.

Oblivion too?
I also ran into that issue and several games seem affected. I wish I had the time to look into that problem and look into what might cause it, but from the outside I can’t see a pattern. It could be some inconsistency on GOG data.

Seems like it should be pretty simple for the devs to fix. Their API can’t find the game, so it’s either misconfigured in the client somehow (asking for the wrong game ID), or it just doesn’t exist at all in whatever database their backend looks at.