GOG Games won't install

I just started trying to use Lutris. When I try to install my GOG games, it appears to go through the motions, but Lutris can’t find the game executable. When I check the game directories, I can’t find it installed anywhere.

Removed the debug log since this seems to be the same problem LeXofLeviafan had previously.

Can you try logging in and out of GOG in your browser?

I just had a similar issue with A Hat In Time, and I think it might be related to something going on with the GOG site - I was able to login, but I am incapable of logging out, which suggests that the auth for their site might be screwed up right now.

I was able to logout and log back in again. I don’t think that is my issue. Whenever I try to install a GOG game, Lutris downloads files, and they’re left in the cache as “download”. However the game’s Windows installation seems not to be run.

Hm, well I’m still having the cookie issue but I managed to work around it by dumping the cookies from my browser. I’m trying to install my game again, and I’ve got the debug window open, so I’ll let you know the results.

So same issue. The files are downloaded, but something seems to be going wrong.

DEBUG    2020-03-13 22:54:33,206 [downloader.on_done:97]:Finished downloading https://content-system.gog.com/products/1686426343/users/46989348093230870/namespaces/website/download?path=%2Fsecure%2Foffline%2F1686426343%2F1686426343%2F53002773575448699%2F6716%2Fsetup_a_hat_in_time_nyakuza_metro_1.12_%2864bit%29_%2835607%29-2.bin&token=eyJhbGciOiJIUzI1NiIsImV4cCI6IjE1ODQyNTEzMzQifQ.eyJjb250ZW50Ijoie1widXNlcl9pZFwiOjQ2OTg5MzQ4MDkzMjMwODcwLFwicHJvZHVjdF9pZFwiOjE2ODY0MjYzNDMsXCJwYXRoXCI6XCJcXFwvc2VjdXJlXFxcL29mZmxpbmVcXFwvMTY4NjQyNjM0M1xcXC8xNjg2NDI2MzQzXFxcLzUzMDAyNzczNTc1NDQ4Njk5XFxcLzY3MTZcXFwvc2V0dXBfYV9oYXRfaW5fdGltZV9ueWFrdXphX21ldHJvXzEuMTJfKDY0Yml0KV8oMzU2MDcpLTIuYmluXCJ9IiwiZXhwIjoiMTU4NDI1MTMzNCJ9.CHuAEvyc32bEXFWnp1Zh3U-gyfdQ-c8132TLKHq9Z0A&access_token=Oe7UVHAKUrryEdL6omcn1jF4mDVuIKF1jIJ2ysRc4ankWGqscpkyDLTCrxtdaUeNotnc-Hd-ybTV-2Zf7iuwL8lXNVz5CWnc3CCWawFk_DSMEI_IIZZIePyhg5DQGKgtKbuAvzWcKUmSZt6BYBwuyg
DEBUG    2020-03-13 22:54:33,676 [interpreter._iter_commands:573]:Installer command: {'task': {'prefix': '$GAMEDIR', 'name': 'create_prefix'}}
INFO     2020-03-13 22:54:33,677 [wine.create_prefix:99]:Creating a win64 prefix in /home/marmalade/Games/a-hat-in-time
DEBUG    2020-03-13 22:54:33,678 [system.execute:38]:Executing /home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/bin/wineboot
DEBUG    2020-03-13 22:54:33,678 [system.execute:44]:WINEARCH=win64 WINEPREFIX=/home/marmalade/Games/a-hat-in-time WINEDLLOVERRIDES=
INFO     2020-03-13 22:54:48,495 [wine.create_prefix:148]:win64 Prefix created in /home/marmalade/Games/a-hat-in-time
DEBUG    2020-03-13 22:54:48,528 [interpreter._iter_commands:573]:Installer command: {'task': {'executable': 'install', 'arch': 'win64', 'args': '/VERYSILENT /SUPPRESSMSGBOXES', 'name': 'wineexec', 'prefix': '$GAMEDIR'}}
DEBUG    2020-03-13 22:54:48,554 [wine.use_lutris_runtime:113]:/home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/bin/wine is provided by Lutris, using runtime
WARNING  2020-03-13 22:54:48,567 [wine.game_exe:543]:The game doesn't have an executable
DEBUG    2020-03-13 22:54:48,568 [command.start:112]:Running /usr/bin/lutris-wrapper 0 0 /home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/bin/wine install /VERYSILENT /SUPPRESSMSGBOXES
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: WINEARCH="win64"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: WINE="/home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/bin/wine"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: WINEPREFIX="/home/marmalade/Games/a-hat-in-time"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: LD_LIBRARY_PATH="/home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/lib:/home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/lib64:/usr/lib/libfakeroot:/usr/lib/openmpi:/usr/lib32:/usr/lib:/usr/lib64:/home/marmalade/.local/share/lutris/runtime/Ubuntu-18.04-i686:/home/marmalade/.local/share/lutris/runtime/steam/i386/lib/i386-linux-gnu:/home/marmalade/.local/share/lutris/runtime/steam/i386/lib:/home/marmalade/.local/share/lutris/runtime/steam/i386/usr/lib/i386-linux-gnu:/home/marmalade/.local/share/lutris/runtime/steam/i386/usr/lib:/home/marmalade/.local/share/lutris/runtime/Ubuntu-18.04-x86_64:/home/marmalade/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu:/home/marmalade/.local/share/lutris/runtime/steam/amd64/lib:/home/marmalade/.local/share/lutris/runtime/steam/amd64/usr/lib/x86_64-linux-gnu:/home/marmalade/.local/share/lutris/runtime/steam/amd64/usr/lib"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: __GL_SHADER_DISK_CACHE_PATH="/home/marmalade/Games/a-hat-in-time"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: __GL_SHADER_DISK_CACHE="1"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: DXVK_HUD="compiler"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: DXVK_STATE_CACHE_PATH="/home/marmalade/Games/a-hat-in-time"
DEBUG    2020-03-13 22:54:48,568 [command.start:114]:ENV: PYTHONPATH="/usr/lib/lutris:/usr/bin:/usr/lib/python38.zip:/usr/lib/python3.8:/usr/lib/python3.8/lib-dynload:/usr/lib/python3.8/site-packages"
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdout = io.open(c2pread, 'rb', bufsize)
Running /home/marmalade/.local/share/lutris/runners/wine/lutris-5.2-x86_64/bin/wine install /VERYSILENT /SUPPRESSMSGBOXES
000b:fixme:winediag:__wine_start_process Wine TkG 5.2 is a testing version containing experimental patches.
000b:fixme:winediag:__wine_start_process Please don't report bugs about it on winehq.org and use https://github.com/Tk-Glitch/PKGBUILDS/issues instead.
0009:err:module:__wine_process_init L"C:\\windows\\system32\\install.exe" not found
Waiting on children
All children gone
Exit with returncode 53
DEBUG    2020-03-13 22:54:49,567 [command.on_stop:161]:The process has terminated with code 13568
DEBUG    2020-03-13 22:54:49,567 [command.stop:246]:Management process looks dead already.
DEBUG    2020-03-13 22:54:49,568 [command.stop:254]:Detaching logger
DEBUG    2020-03-13 22:54:49,608 [game.save:234]:Saving A Hat in Time (wine)
DEBUG    2020-03-13 22:54:49,609 [config.save:208]:Saving LutrisConfig(level=game, game_config_id=a-hat-in-time-gog-dxvk-1584165289, runner=wine) config to /home/marmalade/.config/lutris/games/a-hat-in-time-gog-dxvk-1584165289.yml
DEBUG    2020-03-13 22:54:49,632 [lutriswindow.on_game_updated:721]:Updating game A Hat in Time (wine)
DEBUG    2020-03-13 22:54:49,685 [interpreter._write_config:665]:Saved game entry a-hat-in-time (5)
WARNING  2020-03-13 22:54:49,687 [interpreter._finish_install:618]:No executable found at specified location /home/marmalade/Games/a-hat-in-time/drive_c/GOG Games/A Hat in Time/Binaries/Win64/HatinTimeGame.exe

I don’t know enough about how Lutris functions to really pick out anything here that looks abnormal, but as far as I can tell it seems to be an issue with downloading the files in the strange unnamed segmented format.

I found a way to install some of my GOG games. I’m not sure if it will work for all games as I’ve only tried it on a couple of games so far. Here’s what I did, but no guarantee of its’ effect on others.

  1. Logout of lutris
  2. Remove $HOME/.cache/lutris/.gog.auth
  3. Remove $HOME/.cache/lutris/.gog.token
  4. Login to GOG website with your browser
  5. Download game standalone installer
  6. Start Lutris (Do NOT login)
  7. Search lutris.net for the game
  8. Select the appropriate installer
  9. CLOSE the GOG login popup - DO NOT LOGIN
  10. Then you can select the installer you downloaded from GOG earlier

Obviously this is annoying. Hopefully, the problem with Lutris will be fixed soon.

@marmalade Maybe this will work for you.

Perhaps it is the same issue I ran into yesterday: that downloaded GOG installer files aren’t renamed according to their correct names, but have names like gog_file_*/download (with wildcard being the file number, starting from 0). If it is, I suspect either Lutris got a new bug there, or they failed to anticipate GOG changing their download link format.

What you’re trying to do is prevent the install script from automatically (and apparently incorrectly, now) downloading the installer files. The simpler (and more “official”, I guess) way for that would be to download the full install script (“Download install script” in the script menu, or “download” link in the preview page), and remove the gogid/gogslug identifiers (or replace their values with respective ‘empty’ ones: null/""); then you can install the game using lutris -i <filename>.json command without it trying to download anything.

@LeXofLeviafan Yep, I think you’re right. I also have files named the same as you found in my cache location. Do you know if the devs are aware of this problem?

Yeah. It would be nice if there was an option to choose whether to download or select an already downloaded installer instead of automatically downloading.

1 Like

There seems to be a bug registered which apparently had been fixed just recently (though the source of the problem – the downloaded filenames – wasn’t mentioned in discussion), but the last release was in November so we’ll have to wait for the next one to benefit from the fix (or download the nightly version).

I think there has been an option like that before… Or maybe I’m remembering it wrong and they dropped the selection the moment they added autodownload.