I wanted to use any of your new ge-protonified-*-4.x wine versions with lutris, but they all fail because of a requirement for a too new GLIBC version.
Here is a short summary, trying to run “wine notepad.exe” as a test:
$ ge-protonified-4.9-x86_64/bin/wine notepad.exe
000d:err:module:load_builtin_dll failed to load .so lib for builtin L"msvcrt.dll": /lib64/libm.so.6: version `GLIBC_2.27’ not found (required by ~/.local/share/lutris/runners/wine/ge-protonified-4.9-x86_64/bin/…/lib64/wine/msvcrt.dll.so)
and many more follow-up errors.
Accordingly, an “ldd -v ge-protonified-4.9-x86_64/lib64/wine/msvcrt.dll.so” gives the same error message:
ge-protonified-4.9-x86_64/lib64/wine/msvcrt.dll.so: /lib64/libm.so.6: version `GLIBC_2.27’ not found (required by ge-protonified-4.9-x86_64/lib64/wine/msvcrt.dll.so)
libm.so.6 (GLIBC_2.27) => not found
The system’s GLIBC on openSUSE Leap 15.1 is 2.26. I guess, that the ge-wine versions were compiled under a relatively recent Fedora. Would it possible for you to provide a wine version with a less strict requirement on a newer GLIBC version?
Many thanks for providing your wine-versions to lutris!
The build bot system uses Ubuntu 18.04 which does use glibc 2.27. I’m not sure why Leap ships with 2.26. The build bot had to be moved from ubuntu 16.04 to 18.04 in order for it’s SDL2 libraries to be compatible with FAudio. glibc generally ties into a lot of things, and is not able to be added without breaking a lot of stuff (including python, which lutris relies on). What you may want to do is see if you can obtain an updated glibc build from the openSUSE OBS
Many thanks for your reply. Unfortunately, the OBS glibc 2.29 is for the rolling release openSUSE, Tumbleweed, and would surely break the stable release, Leap.
Unfortunately I’m not too familiar with how to use OBS, but I would suggest maybe contacting one of the 15.0 repo owners with 2.27+ and see if they can make a 15.1 build. I made an attempt but was running into the issue that I could not make i686(32 bit) builds
Sorry dirk but you may need to change distros or downgrade to 15.0. Per 15.1 documentation:
Note: No Support for Building 32-bit Applications
openSUSE Leap does not support compilation of 32-bit applications. It only offers runtime support for 32-bit binaries.
This means no one on OBS will be able to make 32 bit builds for openSUSE 15.1
never mind! Instead of downgrading to Leap 15.0, I decided to take the somewhat bolder step and upgraded to the rolling release Tumbleweed which comes with glibc 2.29. Now, your ge-protonified-4.10 works perfectly!
Good to hear! I’ve heard tumbleweed works very well for gaming. Cheers!
Hi. I’m trying to run Heroes of the Storm with GE-protonified-4.10. I get the following error:
wine client error:0: version mismatch 579/586.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?
Waiting on children
Exit with returncode 1
I’ve tried reinstalling that wine version, but I get the same error.
Also, I try running Battlefield 1 with that version of wine, and I get Exit with returncode 161
I’m using OpenSUSE Leap 15.0, with GLIBC upgraded to 2.27.