Getting Yousician to work properly


If you don’t know Yousician, it’s a software developed in Unity Engine with gamified elements to teach you playing instruments. It has smartphone apps for iOS and Android, a windows and a mac desktop client. They used to have a linux client, but deprecated and dropped support for it.


The actual game part of it works really well. In fact, everything except one little, but important aspect is working really well and that is videos. Each lesson has at least one video that explains the purpose of the lessons and gives valuable information on techniques and so on. These videos don’t work at all and somehow break the application in that if you tried to watch a video you can’t quit the game/app afterwards in a normal fashion (it freezes on exit) and are forced to use “Kill all wine processes”. If you didn’t try to watch a video, you can quit without problems.

Depending on the wine version used there are two different behaviors one can experience when trying to watch a video.

1.) You get an endless loading animation that never results in anything.
2.) You get an onscreen message “Unable to play the video. Are you connected to the internet?”, which I am, because every other feature that requires internet works.


Game info
Runner: Wine (Runs Windows games)

Game options
Executable: YousicianSetup.exe after installation and initial run I changed this to /home/robsen/.local/share/wineprefixes/yousician/dosdevices/c:/users/robsen/Application Data/Yousician Launcher/Yousician Launcher.exe

Runner options
Wine version: lutris-5.7-x86_64 for scenario 1 and System (5.9) for scenario 2.
The rest is on default. If that doesn’t suffice as information, let me know and I’ll add the full config.


As a new user I can only post two links, so you gotta copy paste the rest :frowning:

lutris -d:
game log:

unity output-log:

Yousician installer:

1 Like

In retrospect, I’m not even sure if it’s a log from unity or simply a log the yousician devs put it. But you can find it in your wineprefix c:\users\<youruser>\AppData\LocalLow\Yousician\Yousician

Maybe you don’t have “Output debbugging info” enabled. You can find it by right clicking yousician in lutris -> Configure -> Runner options -> “Output debbugging info”. I have it set to “Enabled”.

I get problem #2 when switching the wine version from lutris-5.7-x86_64 to System (5.9)

With #2 I get the following logs:
game log
lutris -d

Not getting any socket errors here. But apart from that the logs look pretty much the same :confused:

It doesn’t seem to work for me if I do it manually. Your updated install script probably needs to be approved by a moderator before I can use it, because it looks the same as yesterday to me.

Once it’s approved I try it.

Hmm. Weird. If I click edit script, I see the new script, but if I click view script it shows the old one.

Here’s the updated script:

You can install in Lutris by running lutris -i <YAML file>

Is there any particular reason why you’re doing

command: git clone $GAMEDIR/tempdir/mf-install-master

and not simply

command: git clone $GAMEDIR/tempdir/mf-install-master


Edit: Also why are all your posts getting flagged? :open_mouth:

Is there any particular reason why you’re doing

command: git clone $GAMEDIR/tempdir/mf-install-master

and not simply

command: git clone $GAMEDIR/tempdir/mf-install-master

No particular reason. Is it better the other way? I was trying to do a zip download + extract initially, but found this easier. Anyway, does Yousican work for you with the installer?

Edit: Also why are all your posts getting flagged? :open_mouth:

No idea. Someone marked my posts as spam… From my messages:

Your post was flagged as spam : the community feels it is an advertisement, something that is overly promotional in nature instead of being useful or relevant to the topic as expected.

Maybe it’s the excessive pastebin links triggering an automatic flags :smiley:

I get permission errors doing it with The other way works without a problem.

Sadly, no. The background-video on the login screen works now, but the other videos for the lessons still show the endless loading animation. I’m currently at work, so I’ll provide a log later.

Okay, I’ll change the script then.

Were you trying it right after the installer launches the game automatically? It might not have the correct Wine settings since it was launched by the installer. You should try the game when launching it from Lutris.

Also, the endless loading animation still happens time to time to me, so you might want to try again.

Sorry for the late reply, but work was very stressful this week. So far I can’t get it to run with your install script. It always downloads that one windows update and then fails at installing yousician. Here the output from the console (which I post here, because suddendly I can’t link pastebin here anymore):

2020-06-27 16:20:54 (1.43 MB/s) - ‘windows6.1-KB976932-X64.exe’ saved [947070088/947070088]

0078:err:module:load_so_dll failed to load .so lib "/usr/lib/wine/": /usr/lib/wine/ undefined symbol: libusb_interrupt_event_handler
0078:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\wineusb": c0000142
003c:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1114
- amd64_microsoft-windows-mediafoundation_31bf3856ad364e35_6.1.7601.17514_none_fa8534ab236134c4.manifest (win64)
- wow64_microsoft-windows-mediafoundation_31bf3856ad364e35_6.1.7601.17514_none_04d9defd57c1f6bf.manifest (wow64)
- mf.dll -> /home/robsen/Games/yousician/drive_c/windows/system32
- mfps.dll -> /home/robsen/Games/yousician/drive_c/windows/system32
- mf.dll -> /home/robsen/Games/yousician/drive_c/windows/syswow64
- amd64_microsoft-windows-mf_31bf3856ad364e35_6.1.7601.17514_none_ab34ec409a77d93c.manifest (win64)
- wow64_microsoft-windows-mf_31bf3856ad364e35_6.1.7601.17514_none_b5899692ced89b37.manifest (wow64)
- amd64_microsoft-windows-mfreadwrite_31bf3856ad364e35_6.1.7601.17514_none_177bed732ea3f85f.manifest (win64)
- wow64_microsoft-windows-mfreadwrite_31bf3856ad364e35_6.1.7601.17514_none_21d097c56304ba5a.manifest (wow64)
- mfreadwrite.dll -> /home/robsen/Games/yousician/drive_c/windows/system32
- mfreadwrite.dll -> /home/robsen/Games/yousician/drive_c/windows/syswow64
- amd64_microsoft-windows-wmadmod_31bf3856ad364e35_6.1.7601.17514_none_e474f0ac34979bc4.manifest (win64)
- x86_microsoft-windows-wmadmod_31bf3856ad364e35_6.1.7601.17514_none_885655287c3a2a8e.manifest (win32)
- wmadmod.dll -> /home/robsen/Games/yousician/drive_c/windows/system32
- wmadmod.dll -> /home/robsen/Games/yousician/drive_c/windows/syswow64
- amd64_microsoft-windows-wmvdecod_31bf3856ad364e35_6.1.7601.17514_none_20b089c0f6efacae.manifest (win64)
- x86_microsoft-windows-wmvdecod_31bf3856ad364e35_6.1.7601.17514_none_c491ee3d3e923b78.manifest (win32)
- wmvdecod.dll -> /home/robsen/Games/yousician/drive_c/windows/system32
- wmvdecod.dll -> /home/robsen/Games/yousician/drive_c/windows/syswow64
- amd64_microsoft-windows-wmadmod_31bf3856ad364e35_6.1.7601.17514_none_e474f0ac34979bc4.manifest (win64)
- x86_microsoft-windows-wmadmod_31bf3856ad364e35_6.1.7601.17514_none_885655287c3a2a8e.manifest (win32)
- wmadmod.dll -> /home/robsen/Games/yousician/drive_c/windows/system32
- wmadmod.dll -> /home/robsen/Games/yousician/drive_c/windows/syswow64

Now you need to get mfplat.dll in your application directory
Game is considered exited.
Initial process has exited.
All monitored processes have exited.
Exit with returncode 0
lutris-wrapper: /usr/bin/bash
Running /usr/bin/bash -c rm -rf /home/robsen/Games/yousician/tempdir
Initial process has started with pid 41910
Game is considered started.
Game is considered exited.
Initial process has exited.
All children have exited.
Exit with returncode 0
lutris-wrapper: /home/robsen/.local/share/lutris/runners/wine/lutris-5.7-x86_64/bin/wine
Running /home/robsen/.local/share/lutris/runners/wine/lutris-5.7-x86_64/bin/wine /home/robsen/.cache/lutris/installer/yousician/yousician_installer/YousicianSetup.exe
Initial process has started with pid 41928
Game is considered started.
wine client error:0: version mismatch 603/604.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?
Game is considered exited.
Initial process has exited.
All children have exited.
Exit with returncode 256
2020-06-27 16:21:06,549: No executable found at specified location /home/robsen/Games/yousician/drive_c/users/robsen/Application Data/Yousician Launcher/Yousician Launcher.exe

However If I manually install yousician on the same wineprefix after your script fails, video does work most of the time. Sadly when it’s not working the application crashes with the following console output

0046:fixme:winhttp:set_option unimplemented option 59
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option Unhandled dwOption 6
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option Unhandled dwOption 9
00bf:fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
00bf:fixme:wininet:query_global_option Unhandled dwOption 8
00bf:fixme:winhttp:request_set_option 1 (null) (null)
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7b10000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7af0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7ae0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7ac0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a70000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a50000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a40000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a30000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a20000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a00000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff79f0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7980000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff78d0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7770000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffed880000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffed830000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffed810000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffdf610000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffec510000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb1c0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb1b0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb190000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb180000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb170000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb150000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb140000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb130000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb110000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe9ff0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe9fe0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe9fa0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe8b40000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe79f0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe79d0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe7990000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe7910000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe5b10000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe3d50000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe6510000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe3d20000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe5120000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe33c0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe3380000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe24e0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe24c0000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1580000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe2410000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe4710000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1560000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1520000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1510000
00bc:fixme:dbghelp:validate_addr64 Unsupported address ffffffffdf590000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7b10000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7af0000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7ae0000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7ac0000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a70000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a50000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a40000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a30000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a20000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7a00000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff79f0000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7980000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff78d0000
0038:fixme:dbghelp:validate_addr64 Unsupported address fffffffff7770000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffed880000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffed830000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffed810000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffdf610000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffec510000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb1c0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb1b0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb190000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb180000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb170000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb150000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb140000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb130000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffeb110000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe9ff0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe9fe0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe9fa0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe8b40000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe79f0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe79d0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe7990000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe7910000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe5b10000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe3d50000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe6510000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe3d20000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe5120000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe33c0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe3380000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe24e0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe24c0000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1580000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe2410000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe4710000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1560000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1520000
0038:fixme:dbghelp:validate_addr64 Unsupported address ffffffffe1510000
0038:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
wine: Unhandled page fault on execute access to 00003E15 at address 00003E15 (thread 00bc), starting debugger...
0038:fixme:file:CancelSynchronousIo (0000009C): stub
0038:fixme:file:CancelSynchronousIo (0000009C): stub
0038:fixme:file:CancelSynchronousIo (0000009C): stub
0038:fixme:kernelbase:AppPolicyGetProcessTerminationMethod FFFFFFFA, 0032FE9C
00da:fixme:secur32:schannel_get_cipher_algid unknown algorithm 23
00da:fixme:secur32:schannel_get_mac_algid unknown algorithm 200, cipher 23
00da:fixme:secur32:schannel_get_cipher_algid unknown algorithm 23
00da:fixme:secur32:schannel_get_mac_algid unknown algorithm 200, cipher 23
00da:fixme:kernelbase:AppPolicyGetProcessTerminationMethod FFFFFFFA, 0032FE9C
Game is considered exited.
All monitored processes have exited.
Exit with returncode 0

The install script on the lutris page is still the first version. Either no one is approving it or something else is wrong.

I won’t be having much time in the next weeks and I got yousician setup on my tablet now, which works fairly well. So I won’t be able to further help troubleshoot the problem, but I thank you for your time and for getting it to work, better than before.

Hi, I was able to install yousician by modifying your yaml file to install directly like suggested in the forum. Weirdly enough if I download and then install mf it was not working. But now I get an error when starting yousician PIL_imaging.cp37-win_amd64.pyd cannot be extracted . I dont know if it is an option missing?

I got Yousician installed with PlayOnLinux (using the Windows 10 config). I’ve tried with Lutris but I got problem of TrueType not found.
But I have the same problem than OP with the videos: “Unable to watch the video. Are you connected to the internet?”