Back to the main site

Getting a pre-downloaded copy of The Witcher 3 from GOG installed and running on Lutris with Ubuntu 20.04

Hey there

I’m new to Lutris (and loving it so far), so please forgive any silliness in my question. I’m trying to get my already-downloaded GOG copy of The Witcher 3 (TW3) installed and playable using Lutris on my laptop with a 1070 running a fresh install of Ubuntu 20.04.

I was one of the early users of DXVK and managed to get TW3 running on Linux back in 2018 but I’m damned if I can get it running now! So any help would be really appreciated. :slight_smile:

Ma deets:

  • Lutris version: 0.5.6
  • Wine version: lutris-5.6-2-x86_64
  • DXVK version: 1.7L-84bb768
  • Nvidia driver version: 440.64

In the Lutris “Add a new game” dialog, I’ve entered the following information:

  • Game info:
    • Name: The Witcher 3
    • Runner: Wine (Runs Windows games)
  • Game options:
    • Executable: /home/archimime/TW3/setup_the_witcher_3_wild_hunt_1.31_(a)_(9709).exe
    • Wine prefix: ~/Games
  • Runner options:
    • Wine version: lutris-5.6-2-x86_64
    • DXVK version: 1.7L-84bb768

Now, when I save that and select “Play” in the right pane of the Lutris window, I’m guessing the installation executable of TW3 gets launched with the Lutris version of Wine+DXVK. Right, so when I select “Play”, Lutris/Wine does its thing for a bit, like asking to install Mono and Gecko, and then it quietly stops. When I select “Show logs” in the right pane of Lutris I see terminal output like this:

Running gamemoderun %command% /home/archimime/.local/share/lutris/runners/wine/lutris-5.6-2-x86_64/bin/wine /home/archimime/Desktop/TW3/setup_the_witcher_3_wild_hunt_1.31_(a)_(9709).exe
Initial process has started with pid 93927
Game is considered started.
env: ‘%command%’: No such file or directory
Game is considered exited.
Initial process has exited.
All children have exited.
Exit with returncode 32512

So now I’m not sure what to do! This game was working in 2018 with a real old version of DXVK so I’m guessing it must be something simple that I have not got through my head. So, cyberfriendos, what do you think I should do next? Genuinely would appreciate some guidance for a newbie. :slight_smile:

Do you have gamemoderun %command% in your Command prefix field? If so you could try removing it. Or just enter gamemoderun there.

You can find it in the game’s configuration under the System options tab.

1 Like

Ah magic, thanks for your help there. In the System Options tab of the game configurations option in Lutris there was the field Command prefix which had the value gamemoderun %command%. I removed %command% and things seem to be working now. Thanks again for your help!

Welcome to the Wizarding World… :+1:

1 Like