Genshin Impact: Fixing Black Screen on install screen on Linux Mint 21

Edit: Check my reply for better solution

Hi there,

I tried to install Genshin Impact with the install script from lutris, but failed each time on the installation window which stayed black. All other stuff installed well.
I than tried to install the game with epic games launcher where the setup went through installation and the screen wasn’t black. unfortunately they game installed but still missing the anticheat so it wouldn’t run, but at least I didn’t have a black window for installation.

After that I decided to manually install the Windows Application “GenshinImpact_install_mihoyo.exe” from file over lutris.
I don’t know exactly why I get a black screen with installer script but this way it worked for me to NOT get a black window. Maybe someone can explain the difference why it worked this way.
After finally installing an getting the updates I quit the launcher and went coping all files from the manual installation to the one I got from lutris script.

After that I was able to run the patch script but when starting the game I just saw a fullscreen desktop with wallpaper and the game in the top left corner but couldn’t click it. seemed like frozen.

This made me guess it has something to do with virtual desktop and found it in the runner settings of wine for this game.
The Windowed Mode (Virtual Desktop) was enabled which is disabled by default. After switching this the game is finally running.

Guess in this case we could just adjust the script to not use windowed mode in case you encounter same behavior than me.

I will check to see if I can adjust the script myself to use normal mode and not virtual desktop and report back if I got it.

1 Like

If you have dual monitor or more set in your Linux system switch to mirror mode or change screen order for fixing black screen!

As mentioned above I run into a black screen when running the script with desktop mode settings:
args: /desktop=GI,1280x900 $giclient
By removing this from the script I was able to run the script and it worked for me.

Now I got a new PC and had to reinstall genshin Impact, so I ran in the same issue with the black screen again with the script proposed by lutris.

I tried again later with my desktop mirrored to my 2 screens instead of extended desktop with dual Monitors.
The issue with the black Wine Desktop was gone and I could run the script without issues.

Because I switched my TV(second screen) input to another source, my Monitor configuration in Mint changed automaticly from Extended Desktop with 2 Screens to 1 Desktop mirrowed on both screens.

So I started testing around and found out that:

if your primary screen/monitor is on the left or mirrowed it works.
if your primary screen/monitor is on the right it doesn't work.
it doesn't matter on which screen you run the window, 
only the position of the primary screen in system settings matters (left/right)

check out the picture example where you see how monitor/screen settings from Linux Mint take effect on this issue.

Now even if I know how to solve the issue can you help track down if the issue comes from Lutris, Wine, or Linux Mint so that I can report this at the right spot? Sometimes I feel like i have a lot of similar issues with other apps and some could be related to the same issue.

small note:
*with other wine runners I got rid of the black screen in wine desktop mode but the desktop opened on the wrong screen and I wasn’t able to click anything on this desktop. It felt that the mouse position in wine desktop was also 1 screen away from the actual wine desktop. *
not sure about this but remember that I saw the mouse on the left when entering the desktop from right while moving the mouse from the right (primary) screen to the left.

1 Like

THIS worked. I set my primary screen to the left one and this solved the initial black screen. Can we somehow include this on the Lutris main page for the game?

Cant launch the game. I get the screen with the input 1-3 and the desktop with the GI Background but cant do anything there. Tried diffrent runners and resolutions