Back to the main site

Garena SEA - LoL - Failed to launch game

So I’ve just migrated from Windows to Pop! Os and I plan to stream games. I’ve been learning to program for the past few months and Linux is the best kernel for me.

Garena games don’t work, I tried playing LoL but it failed to launch tested the problem in other games, doesn’t work either.

Will there be a fix?

Welcome to Linux and Lutris, and I hope you have fun and learn a lot with programming!

Are you saying that the games you tried don’t work specifically when you run them with Garena? It looks like someone had a similar problem a year ago that was fixed by upgrading Wine: Garena Installation.

Could you please close Lutris and start it in the terminal with lutris -d, try to play a game again, post the output from the terminal at paste.ubuntu.com, and share a link here?

Is it specifically working only in wine 4.3?

https://paste.ubuntu.com/p/w9pQ3XKrf4/

I don’t know, but it could be worth trying a few different versions of Wine. There are a bunch of versions in Manager runners -> Wine -> Manage versions.

Which installer did you use to install Garena? There are two, and it looks like other people have had the same problem as you with the “Windows version” installer. Maybe the “2.0 version” installer works better?

Tried both didn’t work, the other wine version - sadly - doesn’t work either.

Garena runs with Wine 4.3 or above, but no launch games for some reason.

Well thats unfortunate

i also have the same problem “launch failed” have u fixed yours?