Gamemode greyed out/disabled, yet installed & working

I’m on Ubuntu 19.04 and I have gamemode installed from my package repo, which I believe is the 64bit version (unsure if it includes 32bit). I can get Rust through STEAM’s Proton to use gamemode, but with Lutris the toggle is greyed out so I can’t even turn it on Lutris-wide.

Can we please get this addressed? Gamemode is clearly working for me, and I would like to use it with Lutris.

1 Like

Personally I’d get a refund

Facepunch has no intention to support linux. If you get it working its pure fluke and will prob break in the future. In fact they even state so in the blog post that I gave.

Can you seriously not stay on topic ffs? >:|

On Ubuntu base, is
Feral game mode is greyed out for me also,
But it does work.
I ‘manually’ added it in Lutris System options under Environment variables loaded at run time.

For me on Xubuntu

I just tried that and my gamemode watching gnome plugin reports gamemode does not start. :frowning:

I use the terminal command gamemoded -s to verify it is working. Also I am on Xubuntu 18.04 had to use PPA to install. I can only suggest to use the find command. Maybe on 19.04 it is in a different folder, or maybe the 0 has been dropped from end of filename on 19.04. good luck sorry can’t help more

I used this vid to set it up in Lutris

I’m having the same issue. Gamemode is installed but the option to turn it on in Lutris is greyed out. I was able to enable it Lutris-wide by adding LD_PRELOAD | /usr/lib/ to my Lutris environment variables. I then verified it was working by running a game and typing gamemoded -s into my terminal.

I fixed it. You have to also install lib32-gamemode. That was in the instructions, so I’m not sure how I missed it.

I double checked the location before testing, was following the same thought pattern. File exists, precisely the same way you typed it, but did not appear to trigger gamemode for me.

This isn’t in the mainline PPAs, not sure where you got that package from :confused:

Okay, so the trick for me was setting




I set it in the global Lutris “System Preferences” section, under “System Options” in the “Environment Variables” section. Now, as outlined earlier by others, this applies globally, and appears to actually get my gamemode monitoring tool to pick up gamemode daemon is operational. I did not have to toggle “Enable Feral gamemode” in the same section (global or per-game/app), it just did it anyways.

This is kind of silly, as really, I clearly have a working gamemode install, why can’t we just have Lutris pick up on that and allow the toggle? Instead of having to set an Environment Variable. This really is the original point I was trying to make.

That being said, thanks to those for helping me figure out a work around. IMO, Lutris should be updated to enable that easy toggling in scenarios like mine (where it is present).

1 Like

I think it is because of the difference between distributions. I can report on Xubuntu 18.04 enable feral gamemode is greyed out even though gamemode is installed. Knowing what distros it works with and which it don’t will need to be known by the devs to fix it. For me this is very minor…the Lutris devs rock and are doing a great job IMHO

I’m on ArchLinux. I just installed it from the AUR.