Game spikes temp despite being small (might have a workaround)

I’m having an issue with an RPGMaker game that I run through Lutris. Whenever I run Weird and Unfortunate Things are Happening, the cpu temp steadily rises, despite only using 18-20% of the CPU (according to system monitor). Its gone as high as 95 (where I promptly shut the game off). This happens over the course of about half an hour. If the game window is out of focus, temperatures drop back to normal pretty fast.
I don’t know what would cause this, rpgmaker games are pretty light on resources. I’m on an ASUS RoG Zephyrus laptop.
Operating System:Mint 20,3 Cinnamon
Cinnamon version: 5.2.7
Kernal: 5.4.0-99-generic
Processor: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx × 4|
Memory: 7.5 GB
Graphics Card: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile]

My system should be way beyond able to run this. Its the only game to do this so far.
Anyone else experience this?

I might have found a workaround for now. By lowering the game’s priority, I can limit the heat spike a bit. Its still getting up to 80-82 degrees, but at least its not 95+. Still far more than this game should be taking, but at least its more playable now.

1 Like

It sounds more like a cooling problem. Either your heat sink has a bad mount, or perhaps your system fan is not coming on when it’s supposed to. On a laptop, quite possibly the latter if power management is not working correctly. Do you hear your system fan running or feel air out the side vents or anything when this happens?

Laptops are a bit of a different animal, but still that indicates something wrong. 100% CPU usage on all cores should not bring that up that high. (I could see approaching 80 with a crappy cooler)

Start a compile job on all cores or something and observe your CPU temp. It could go critical in a few minutes, so ctrl-c it to stop it if it does.

It could even be something like, power management not working correctly while playing a game, e.g. while the nvidia graphics adapter is engaged. Or is it even switching to the dedicated GPU?

I know its not any of those. Other games and applications work fine. Its this rpgmaker game specifically, which is weird, because this is the least resource intensive game I’ve played on Lutris.

You may want to try to limit the FPS for this particular application. You should check if the application has an option to do this. If not - see your nvidia settings or lutris+mangohud. If for example your screen runs at 60Hz refresh rate, try to limit the software FPS to 60. Also make sure to change the setting for the GPU being used - it is quite possible that the software runs on the integrated device, instead of the discrete one.

Okay, I’ll give that a shot. Thanks.

Oh, and thank you for taking the time to read and respond here. I really appreciate it.

The GPU is set to use the discrete one, I double checked. I tried mangohud, and I can’t get it to run or display. I tried goverlay to run it from a GUI, and it doesn’t seem to want to work with Lutris. Lutris has an FPS limit option, but its greyed out.

That’s the reason I suggested that maybe you weren’t using the discrete GPU. You say the CPU usage wasn’t very high, yet the temperature was going all chernobyl.

The integrated graphics device is right on the die.

I wouldn’t know how that could happen, since I can’t switch GPUs on demand. If I want to switch, I need to manually change it in settings, and then log out and back in. I just keep it set to use the discrete GPU to avoid messing with that.
According to the GPU settings, I’m using the right GPU. According to Lutris, Its using the discrete GPU. I’m not sure what could be changed. On the flipside, its a 2D pixel rpgmaker game, a toaster can run it. Integrated vs. discrete shouldn’t be making a difference. And yes, I’ve tried switching between discrete and integrated in the settings, and it doesn’t change the temp issue.