Back to the main site

Galactic Civilazations dosen't work


#1

I searched on the Lutris web site and clicked install to run the script. The game will not run. Steam says ‘wrong platform’. I checked the runner. It was set to Steam for Linux. I switched it to wine steam. Steam still says ‘wrong platform’. What is wrong and please fix your script so others don’t get this problem.


#2

Which one exactly? GCI or GCIII?


#3

three


#4

Since I can’t test it I can’t guarantee the game will work but the wrong platform error should be fixed.


#5

I am reinstalling it to test. I will post here whether it works or not. Please wat about 15 minutes.


#6

Now he game just quits with no error message.


#7

I don’t know If this helps. In the games lutris client config, the game options tab, in the prefix box it says ‘None/prefix’.


#8

Do you have wine installed on your pc? https://www.gloriouseggroll.tv/how-to-get-out-of-wine-dependency-hell/

I don’t know If this helps. In the games lutris client config, the game options tab, in the prefix box it says ‘None/prefix’.

It should look something like this:

Prefix: ~/.local/share/lutris/runners/winesteam/prefix/drive_c/Program Files/Steam/steamapps/common/Grand Theft Auto IV/prefix


#9

Yes. I have other Steam for windos games installed such as Ever Quest. I also play EQII but lutris does not have an installer. EQ plays just fine.


#10

I just tried to uninstall it so I could try it again. It will not uninstall. Is there a way to manually uninstall a program. Maybe delete some directories or something.