FYI: By default Lutris uses a wonky version of wine

I’m not super technically adept so please keep in mind, that my advice might be wrong:

On a new install of Linux, I installed Lutris from both the repositories and flatpak, however my games wouldn’t launch in either.

Until someone suggested switching the wine version under Runner Options.

By default it sets to: wine-ge-8-25-x86_64, which didn’t run any games for me (and I’m told won’t run games). I switched to the only other wine version available (System 8.31) and at least one game that didn’t run earlier (Civ IV) works fine now. I have yet to test out other games that weren’t working.

Just an FYI, maybe it would be a good idea to have a different wine version set as default.

Yeah it is not using a wonky version of wine - there are only a small handful of games that don’t run with this version of wine, and it is based on the same wine source (proton) that Civ IV uses to run through steam.

I just saw your other post - check what you have in the preferences → global options → enable Advanced → vulkan ICD loader field. If it is set to unspecified, change it to match your gpu and not say unspecified.

So you were right about Vulkan ICD Loader Field being set to unspecified. I specified the open source drivers for my AMD GPU.

However switching back to the default runner, and the game isn’t loading again.

Which means - get some debug data per the pinned message.

So since this wasn’t a support post per se (my intention was to point out what I thought was a possible bug/mistake), I didn’t include logs. One of my earlier posts does include logs per the pinned message

But if you are interested, here is the log with the updated Vulkan ICD Loader setting & using the default runner option

need from the lutris -d in terminal onwards - close lutris and launch it with lutris -d in terminal
copy the output from the lutris -d to the end point - the preamble lutris provides at launch is what I need to see

Sorry for the late reply: I think this has what you want.

Logs for Vulkan ICD set to GPU, but with default runner (generated in the way you outlined by running lutris -d)

Well this is a puzzle - if you want to try an earlier wine version, lutris 7.2-2 is probably the most stable earlier version (the Wine Manager on the left tab in lutris under runners can help install it). It is funny because this issue is not present on the Proton 8 running Civ in Steam - which makes me wonder if you have multilib enabled (link)

So this is kind of above my understanding: but to clarify I have a default installation of Manjaro and I haven’t fiddled with anything (however perhaps installing Lutris or something may have fiddled with my settings).

Checking pacman.conf, the multilib section isn’t commented out. Which makes me think it is indeed enabled

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

Wait a sec - are you trying to use virtual desktop with Wine (runner options tab)? That is no longer supported in Wine.

Try the wine 7.2-2 version see if that runs it for you - also try enabling fsr on the runner options tab - it will upscale the game resolution to your default monitor resolution.

I think gamescope also works, but not sure how to install/configure this on Arch

I’m not purposefully using a virtual desktop. Again I just let the installer script do its thing, if it’s setting up a virtual desktop, then that’s what I’m using (and looking at the logs, it does seem to say that).

Regarding 7.2-2, I had to manaully download that, but it works (fsr was already enabled). Which leads me back to my initial message: the default wine runner doesn’t work (for me and a few others I’ve asked for help online, I assumed for everyone).

Regarding Gamescope: the option does exist under System Options (its a simple tab). I’m not sure if enabling it does anything though.

No - your original assertion is still incorrect - the install script should not be setting a virtual desktop WITHOUT specifying it needs to use lutris-ge7.2-2 as the wine version. Like I said there are only a few games that don’t run on GE8-25, this is an install script error that I have flagged on discord for someone with the game to fix. On Steam, it is listed as running with the GE 8 or Proton 8 wine versions. So hopefully someone will be on the case and just add the correct fix to the installer.

Just as another update: I tried another game (Fallout 3) and was running into the same issue (wouldn’t launch). I tried switching to 7.2-2 and it launches now (though there is some stuttering/crackling audio which definitely didn’t use to exist earlier even though I’ve selected the reduce audio latency option.).

I’m not sure if this is also a virtual desktop issue, the installation was done using Lutris’s install scripts.

DEBUG 2024-01-22 10:56:51,392 [prefix.set_virtual_desktop:285]:Enabling wine virtual desktop with default resolution of 1920x1080

In lutris, on the left hand pane under runners, select wine and then the gear icon
Make sure you do not have virtual desktop enabled here

For the audio issues, check on the runner options tab and change the audio driver from default to a selected option (no idea if your system uses pulse or pipewire) - this may help

Just as a followup to this: I tried a different distro and the default version of wine works fine.

So my issue seems to be distro specific.