[flatpak] Can't initialize graphics in WoW and Warcraft 3


I’ve installed Lutris as a flatpak and am having issues with some games on Battle.net, currently Warcraft 3 and World of Warcraft, though HearthStone works kind of fine and I haven’t tried other games.

When trying to launch W3 or WoW, I get a message saying that it can’t initialize graphics or that my GPU is too old. I’ve tried to launch my Battle.net install using the regular system Wine, without going through Lutris, and both W3 and WoW start (I get a black screen with W3 but that’s another story).

So, I’m suspecting there is something broken with the flatpak version of Lutris interacting with Mesa (which is itself packaged as a flatpak runtime, flatpak apps don’t use the system Mesa). I’ve seen another topic that suggested that flatpak Lutris was unable to use Vulkan and I’ve seen other topics with similar “can’t initialize graphics” issues but I’m not sure it was with flatpak Lutris in these cases. So, it’s a bit of a mess to find proper informations.

So, basically: are there known issues with flatpak Lutris and Mesa/Vulkan, and a possible solution?

I can add that I also use Steam as a flatpak (so, flatpak Mesa too) and never got similar issues.

1 Like

What is the version of Lutris in flatpak? You might need to run flatpak update to get the latest packages.

I’ve updated the flatpak packages, I do it on a regular basis. It’s 0.5.11.

Try bottles - the Battle.net installer works well there. Do you have an igpu and dgpu in your system?

No, it’s a desktop PC, with only one GPU (Radeon).

But I don’t want to use Bottles, I’m trying to use Lutris. More specifically, trying to find out why I have these issues with the flatpak version while the non-flatpak one works better (to some extent).

Not sure this is related but I get this error in the logs/terminal when using flatpak Lutris:

ERROR:dxva_video_decode_accelerator_win.cc(1397)] DXVAVDA fatal error: could not LoadLibrary: msmpeg2vdec.dll: Module introuvable. (0x7E)

When searching for more information, I found a post on Reddit of someone having a similar issue with Overwatch 2 who fixed it by changing the ICD loader in Lutris’ settings but with my GPU I only have two: AMD (default) and Intel. I’ve tried Intel just in case with no change.

FWIW the issue seems to have been fixed by itself. When updating flatpak apps, I got an update for Mesa and Lutris at the same time, so I’m not really sure which one did it.