(FIXED) TeamSpeak+SaltyChat, TeamSpeak crashes constantly


No Matter what version of TeamSpeak is used, ie 3.5.6 32bit which only works with ‘SaltyChat’ “3.1.1 Stable” as the next version of SaltyChat 3.1.2 doesn’t work with the 3.5.6 TeamSpeak API and only works with the 64bit version of TeamSpeak which is 3.6.1.
The problem here is with TeamSpeak you need to install dotnet461 with winetricks and that is broken in any version of WINE even in the 32bit version so you have to force the install with winetricks -q --force dotnet461 etc etc
This does finish with both, and also you need to install ’ Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 either in the 32bit or 64bit etc

Anyone had any success with TeamSpeak at all? Or is this broken now?

I found the fix: I am using TeamSpeak 3.6.0 32bit (altered the SaltyChat script and tested it with that version, and did this bellow:

Put this in the Arguments section of Game Options in Lutris:


This disables any plugins, and will get rid of the crashing so you can login, and then shut it down again.
I found the problem to be the ‘gamepad_joystick’ plugin so if you then remove:



Remove the bellow from Arguments section of Game Options in Lutris:


Then you can start TeamSpeak again without the gamepad_joystick plugin

To install SaltyChat plugin unpack it with an archive manager, and copy the files into:

This then fixes the crashing.

Bro i have the same problems since some days. I’m not using Lutris but okay, i tried to found a fix for that problem EVERYWHERE but nothing worked. I followed the last post and didn’t worked…
Do you have discord?