Back to the main site

Final Fantasy XIV (14) Configs problem


#1

I’ve recently run into a problem with ffxiv with the most recent version of it. The problem is that many config files of it get zero’ed by the game itself on write.

Game stores configs and characted data in C:\users(username)\Documents\My Games\FINAL FANTASY XIV - A Realm Reborn\

Game’s config is stored in file FFXIV.cfg and character data is stored in folders FFXIV_CHRxxxxxxxxxxxx where xxxx are some hex id, seemingly. Character data is stored in multiple DAT files.

So for example all data is fine and dandy. You try to launch game, everything seems to be ok, then you adjust some settings or exit the game and find out that FFXIV.cfg now has size of 0 bytes and is completely empty. Restoring configs and launching game again, loading character will cause some DAT files in character folder to be zeroed as well.

Launching game with zeroed FFXIV.cfg will cause game to get stuck at loading screen before the character select screen (which was original symptom i was trying to fix). Getting to character select with zeroed DAT files will make game say that character data is missing and ask you to re-initialize it.

My best guess is that latest patch, which supposedly came out recently (game shows 2018.08.02 but i’m not sure if that’s the real release date because they did release an update with Monster Hunter cross-promotion recently and last update news is 7.8.2018, and the earliest i got this problem was 8.8.2018) broke something in the game, because according to apt logs there weren’t many updates between now and last time i played the game. Seemingly, only thing that could’ve affected anything is nvidia drivers, but i’ve yet to re-test how dx9 version of the game handles the files.

I run on Lutris 0.4.18.1, wine 3.13 staging by WineHQ (not system’s one), DXVK 0.64, however i did not use install scripts because i run steam version (but really it’s the same thing). I did install xact with winetricks. It uses its own separate wine prefix.

FFXIV’s Launcher does not have this behaviour and it seemingly saves its FFXIV_BOOT.cfg file correctly (i need to verify it tho, but launcher does remember that i use dx11 and my username)

Killing Floor 2, running on global lutris prefix works completely fine with same wine version and dxvk.


#2

Ok, after some extensive testing i found the problem and it lies with Wine 3.13, such behavior isn’t present with Wine 3.12. Issue on WineHQ: https://bugs.winehq.org/show_bug.cgi?id=45614