Back to the main site

Final Fantasy 14 won't start after latest update (DXVK)


#1

Greetings,

There’s a new patch in the water, and I started up Lutris to log in. Sadly, I got a black window and a textbox with a message: “A system error has occurred: 404 HTTPS System Error”. Clicking the OK button just closed the app. I tried a few things (Deleting the profile data in the local Documents folder, reinstalling from scratch off the Lutris website, a couple config tweaks) and none of it made a difference. I’ve included my debug logs:

https://paste.ubuntu.com/p/jzT2DFxqPM/
https://paste.ubuntu.com/p/SHVjNg8Db8/
https://paste.ubuntu.com/p/TfbP4HbNSW/

Thank you in advance for any assistance you can provide.


#2

Just to reiterate, i’ve also faced the same problem. Tried reinstallation, changing wine versions, changing .cfg browsertype and removing web folder.

I’m not sure how to debug from here.


#3

Yeah, seeing the same thing here. Broken with Wine and Proton too.


#4

This thread on the official forums seems to think the issue is due to the launcher calling the wrong URL.


#5

Issue on valve’s proton repo:


#6

Broken for me as well. Hope we find a workaround soon!


#7

Went past the HTTPS 404 by using mitmproxy and the following :

def request(flow):
if "/version_4_0_win/version_4_0_win/" in flow.request.url:
    flow.request.url = flow.request.url.replace("/version_4_0_win/version_4_0_win/", "/version_4_0_win/")

And pointing wininet to the local proxy by changing the registrey keys specified in Wine FAQ.

The wininet will let you bypass the locally generated certificate but after that, the launcher loads a bunch of resources and its a black screen.

Getting stuck on this :

0030:fixme:mshtml:OleInPlaceActiveObject_TranslateAccelerator (0x1212de8)->(0x32f658)
Not sure how far we can go from there without a Wine patch or/and SQUEX support.


#9

If I have the steam version, how do I proceed ?


#11

That runner doesn’t seem to work for me. Just exits with error code -4. Any ideas?

As a side-note, I’ve been trying to build a package with https://github.com/Tk-Glitch/PKGBUILDS/tree/master/wine-tkg-git and the packages compile correctly and everything but when I run the resulting bin the process just freezes on startup. Probably something weird with my customization.cfg. I’ve tried with
staging-esync-dxvk-faudio-marchopt, staging-esync-marchopt & staging-faudio without any luck. Anyone could share their working customization.cfg?
EDIT: And now also the current customization.cfg on the master branch. Still the same symptoms, just freezes : /


#12

Not static enough:

.local/share/lutris/runners/wine/wine-tkg-git-lutris-ffxiv-4.6.r9.ga0708adf/bin/wine: Relink /usr/lib32/wine/ntdll.dll.so' with/usr/lib32/librt.so.1’ for IFUNC symbol `clock_gettime’
Waiting on children
Exit with returncode -11


#13

Yeah, learned the hard way that you cannot share those out of the box, sorry about that. Presumably lutris will have a proper build very soon :slight_smile:


#14

So I managed to download the updates on a VM and install the python launcher. How can I run the Lutris instance in the python launcher? I tried adding the wineprefix command but the game crashes to blackscreen. Is there a command to run the ffxiv_dx11.exe using lutris directly ?

This is the settings in launcher config:

#Leave blank for windows or MacOS, ‘wine’ for Linux
pre_command = wine

I was thinking of simply changing this to lutris but that did not work.

Trying to set the ffxiv application to the python script returns a invalid application type error in Lutris.


#15

That’s a bug in the latest commit of wine-staging.

You can either change the staging version to an older commit with _staging_version="a0708adf427a61acd2f68dda8ccf245d93909f15" or use this patch

Source: https://github.com/Tk-Glitch/PKGBUILDS/issues/170


#16

I think what I was asking was what would be the command line arguments to pass the login info straight to the lutris instance of ffxiv_dx11.exe?

I know normally a lutris application is launched with the following command:
lutris lutris:rungameid/1

The problem is, the python launcher script can’t pass the username / password / key variables from the launcher to the application using that method. Even if you change the lutris application to the ffxiv_dx11.exe file it says you must use the ffxivboot.exe instead.

I’m trying to find a way to do something like this:

lutris game/ffxiv_dx11.exe [args]


#17

Thanks! That did the trick.


#18

Well I just built the latest TKG. There is already a patch for FFXIV and the bug in wine-staging. So after a quick edit of customization.cfg to enable the ffxivlauncher_fix and DXVK it just built fine and installed itself. I now have to wait for the game to download again - I deleted my install yesterday trying to fix it :frowning:


#19

So how do I set up my batch file that runs the python launcher to use the Lutris installation / environment?

echo "FFXIV DX11 Custom Python Launcher"

WINEPREFIX="/home/astump/Games/final-fantasy-xiv-a-realm-reborn"
cd "/home/astump/Games/final-fantasy-xiv-a-realm-reborn/drive_c/Program Files (x86)/SquareEnix/FINAL FANTASY XIV - A Realm Reborn"
./launcher.py

^ this is the batch file I have.
But the custom python launcher does not take arguments if I try to edit the ini file and put this in:

#Leave blank for windows or MacOS, ‘wine’ for Linux
pre_command = wine _staging_version=“a0708adf427a61acd2f68dda8ccf245d93909f15”

it says: [Errno 2] No such file or directory: ‘wine _staging_version=“a0708adf427a61acd2f68dda8ccf245d93909f15”’

I looked at what Lutris does and I tried running the command that it first executes to set the “runner”

/home/astump/.local/share/lutris/runners/wine/esync-staging-pba-ffxiv-3.16-x86_64/bin/wine

this made some changes to my default wine prefix in ~/.wine , thinking - ok, maybe if I mock what Lutris does maybe it will let the ffxiv_dx11.exe run under Lutris’ configuration. No luck except a bunch of files changed in my default wine prefix.

I get there is a bug in the latest commit of wine staging, but I have not updated wine at all or lutris. All I did was copy files from the lutris installation to a virtual machine with a trial of Windows 10 enterprise edition, run the launcher there to update everything, and move all files back per some other instructions I saw. This bypasses having to use the launcher to download and in theory all I would have to do is use the custom launcher to launch Lutris and pass the custom launcher arguments, through lutris, to ffxiv_dx11.exe

In addition for some reason even after doing things this way the WINEPREFIX is not being passed to the custom FFXIV Launcher –

fixme:winediag:start_process Wine Staging 2.4 is a testing version containing experimental patches.
fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.

Because when I run Lutris by default, it should be 3.1x w/ DXVK


#20

Anyone know how to make this into a self-contained package ala the format downloaded by the lutris runner manager? Right now I have to have it installed as my system wine version which isn’t really ideal.


#21

In customization.cfg, change _EXTERNAL_INSTALL="false" to _EXTERNAL_INSTALL="true". And make sure that _EXTERNAL_INSTALL_TYPE is set to lutris.


#22

So is there a Lutris downloadable runner I can install w/o compiling from source yet?