FFXIV TexTools won't start (error .NET v4.7.2)

Opening the app just don’t work. Tried to install “sudo winetricks dotnet40” but that didn’t help.
Still says: “This application requires one of the following versions of the .NET Framework: .NETFramework, Version=v4.7.2”.

Install + first launch:


Error message:

Edit: Forgot to mention i’m using the Lutris browser install, Textools

make sure your Wine is 32bit you cant install NET on 64bit. don’t know about TexTools but I got the Benchmark to work in wine. Final Fantasy XIV Shadowbringers - Benchmark - Maximum Settings (1080P) (GTX970) - YouTube

This is what i get when i switch prefix architecture to 32.

lutris-wrapper: FFXIV TexTools
Started initial process 20327 from /home/—/.local/share/lutris/runners/wine/lutris-fshack-6.21-6-x86_64/bin/wine /home/—/Games/textools/drive_c/Program Files (x86)/FFXIV TexTools2/FFXIV_TexTools.exe
Start monitoring process.
esync: up and running.
wine: WINEARCH set to win32 but ‘/home/—/Games/textools’ is a 64-bit installation.
Monitored process exited.
Initial process has exited (return code: 256)
Exit with return code 256

I have no idea how to install it with 32 bits. Quite new to this kind of stuff.

WINEPREFIX is where your wine folder is I would recommend making a new called .wine32 and install in that folder. WINEARCH is the one that decides if wine is 32 or 64 bit
open Terminal and put in WINEPREFIX="$HOME/.wine32" WINEARCH=win32 wine wineboot to make a 32bit wine folder.
then under your home folder, you can now see a folder called .wine32 if you have said show hidden folder. I’m not sure how you installed it but if you used an exe file then just put WINEARCH=win32 wine "exe location here" in the terminal and it will use the 32bit wine.

Ok so, i’m running manjaro and i did just that using:

$ WINEARCH=win32 WINEPREFIX=~/win32 winecfg
$ WINEPREFIX=~/win64 winecfg

From the ArchWiki.

Now my home folder looks like this:

But when i use:
$ WINEARCH=win32 wine "/home/******/Games/Install_TexTools.exe"
The response is:
wine: WINEARCH set to win32 but '/home/********/.wine' is a 64-bit installation.

So what am i to do from here?
Will textool be able to reach FFXIV ?

hm… i only used Arch once so I can’t say for sure but it looks the same as on pop and ubuntu.
You can try WINEARCH=win32 WINEPREFIX=~/win32 wine "/home/******/Games/Install_TexTools.exe"
or export WINEARCH=win32 wine `"/home/******/Games/Install_TexTools.exe"

Also if you use ctrl+h then you can see a hidden file I bet there one called .wine it use and not the other folders which is why I recommend calling it .wine32

First of all, Thank you very much for the response. I’m loosing hope that i’ll get this to work.
So i ran:
$ WINEARCH=win32 WINEPREFIX=~/win32 wine "/home/***/Games/Install_TexTools.exe"

And it seemed to install both textools and .NET. This after i’ve ran all sorts of installs via terminal incl
$ winetricks dotnet472 Don’t think that helped me but hey, just one of all the stuff i tried.

So im not sure what did it, i renamed the folders to .win32 and .win64. Yes there is a folder called .wine but not .wine32. All seem to have stuff installed in them and at this point im not sure what installed what. Textools is installed in the .win32 folder. But FFXIV is installed in an all together diffrent folder under ~/Games/ and i don’t see how Textools would interact with the game as it is now.

What i do know is that:
WINEARCH=win32 wine "/home/***/.win32/drive_c/Program Files/FFXIV TexTools/FFXIV_TexTools/FFXIV_TexTools.exe"
Still give’s me:
wine: WINEARCH set to win32 but '/home/***/.wine' is a 64-bit installation.

So as i said, im kind of giving up here.

…but maybe there’s still hope?

remember to change the command to the right folder after renaming them so its WINEPREFIX=~/.win32
Also, I just saw that Lutris has an install scrip try that one to see if it works

Before i give it a new try.
My whole initial reason for opening this support thread comes from that lutris install (i just pressed install, open with lutris via browser).
All paste are from it.

Is there a difference between using the install button and actually downloading and running the script?
Should i report this somewhere else?

Im testing it out atm i think you manual need to install NET.exe I’m testing that now since wintrick don’t go as high as 4.7.2

It worked! Ok, here’s what you do. You install the script with lutris, which will install the program for you, but it says it needs NETFramework 4.7.2 when you start it. it has also installed a folder called textools in your home folder if you have not changed the install location in lutris. You need to download this https://go.microsoft.com/fwlink/?linkid=2088631. It NETFramework 4.8 offline, the newest version. After downloading it, you open lutris, and in the top left corner, you click on the cross (add a new game) under the name you are just going to call it whatever you like. Under runner, you choose Wine. Then you click on game option on the top and under executable, you choose the exe you just downloaded. Under wine prefix, you select the textools folder, and that it click save and start the by double-click on it and wait to it finish after that, you should be able to run the program.

If its to hard to understand i could easily make a video showing you how.

1 Like

A video is always superb imo :slightly_smiling_face:.
I’ll try it tomorrow anyways. Getting to late for me.

btw is it not superior to actually update the script?

i dont think so as long you use the Folder it made when installing it.

Wow nice one!
Got it installed and all via you guidance.

Next problem, it crashes all the time :confounded:

The textools windows is black and when i hover over buttons they appear(very flickery). But when i click, it crashes.

Do you open it with lutris? Try to change the Wine version under runner options and see if that helps i had no problem on my pc to run it i just didn’t have anything to add to it.

What version of wine do you use?

I’m using lutris-fshack-6.21-6-X86_64
And picking my other option lutris-6.21-6-X86_64 broke it.

Here’s a little GIF on what it looks like for me.

I use WinHQ-dev so i have Win 7.0.RC2 im also on POP!_OS so it can also be thats why.

since i more or less never used arch more then once i think this is the right command for the Wine i use.
sudo pacman winehq-devel

you can also try to install 4.7.2 offline the same way

i just need to install the game to test if it works since i don’t have the folder it looking for

Thats not going to happen i see

ayers are currently experiencing extremely long wait times due to the dense concentration of play hours which far exceed our server capacity, especially during the peak times, and so we have decided to temporarily suspend the sale and delivery of FINAL FANTASY XIV Starter Edition and Complete Edition. Additionally, although those with an active subscription are prioritised to log in, Free Trial players are unable to log in outside of late night and early morning hours, and so we will also temporarily suspend new registrations for the Free Trial.