FFXIV stuck connecting to data center

I have run into a problem, I launched FFXIV and the game gets stuck at connecting to data center. I am not sure what I can do to get past being stuck connecting to data center.

When I choose a data center I get an infinite loading symbol on the bottom right.

I’m having the same issue. Doesn’t matter which option I choose, first or second, I’m always stuck with a black screen and the loading doughnut in the bottom right. The game also asks me every time if I want to setup my controller despite having done that already. I already copied my character settings to the appropriate path from my Windows version; the folder was not created automatically. That apparently worked for people before, but not for me.

I downloaded the “Official version + XIV installer” from Lutris. My distribution, if necessary, is
PRETTY_NAME=“Solus 4.1 Fortitude”

It was a fresh install. Updated everything on login, installed wine 5.22. Help would be much appreciated.

"I’m having the same issue. Doesn’t matter which option I choose, first or second, I’m always stuck with a black screen and the loading doughnut in the bottom right. "

Hello, try this:
in “my documents/my games/FINAL FANTASY XIV” or similar folder name,
you will find a file called FFXIV.cfg
open it and tell me what is the value of CutsceneMovieOpening ?
Should be 0.

I looked in the FFXIV.cfg and the CutsceneMovieOpening was 1 but I changed it to 0 and I’m still getting the black screen with infinite loading icon.

I am using Manjaro Xfce 20.2
I have Wine 5.22 installed
I am using I’m guessing the latest version of Lutris 6.0
I have updated and installed everything that is required.

Yeah, that was the issue for me; the setting was 0. A friend had worked with me on that, I’ve been playing the past hour already. I had copied my Windows settings folder to the path I was used from Windows, however, Lutris created the settings on a slightly different path so I simply missed it because I didn’t think of looking there. It was pure coincidence that I found it. Don’t ask me why it did that, it’s really dumb. But it worked! I can play quite well now.

Kyaram it is a bug in the FFXIV Lutris script, I could fix it.
Could you tell me where did the script installer copy your FFXIV settings?
And where it should be copied?

Tempus --> could you answer this questions too?

FFXIV.CFG is the settings correct?

For me Lutris installed into /home/shawn/Games/final-fantasy-xiv-online/boot

tempus, the file should be in “My Documents/My Games/Final Fantasy XIV” folder, you have nothing in this folder?

Legluondunet - Only thing in the “My Documents/My Games/Final Fantasy XIV” folder is the boot and game folder and nothing else

There was a bug in the script that manages option file creation, could you reinstall the client, should work as expected now.

You’ll want to adjust ffxiv.cfg to useCutsceneMovieOpening 1 not 0. 0 is what sets the cutscene to play.

I just fixed this in script installer.

I have the exact issue OP originally described, but CutsceneMovieOpening is set to 1. I’ve tried setting it to 0 just to check, neither change anything.

I’m attempting to run the windows version on steam deck.
(Steam version of the game not a valid solution, Squeenix in their infinite wisdom lock your account to the first version of the game you play. I have a wholly useless version of FF14 on my account I need to refund)

I ran logging and got a bunch of warnings and an error, but don’t know what to try next.

This isn’t all the warnings but they are all very similar about Failed to load plugin related to gstreamer. Posting them all goes beyond the character limit.

(wine:1245): GStreamer-WARNING **: 18:57:26.812: Failed to load plugin '/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstaudiofxbad.so': /usr/lib/i386-linux-gnu/gstreamer-1.0/libgstaudiofxbad.so: wrong ELF class: ELFCLASS32

(wine:1245): GStreamer-WARNING **: 18:57:26.813: Failed to load plugin '/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrtmp2.so': /usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrtmp2.so: wrong ELF class: ELFCLASS32
027c:err:winediag:wma_decoder_create GStreamer doesn't support WMA decoding, please install appropriate plugins
027c:fixme:ole:CoCreateInstanceEx no instance created for interface {00000000-0000-0000-c000-000000000046} of class {2eeb4adf-4578-4d10-bca7-bb955f56320a}, hr 0x80004005.

Any ideas?

Uuugh, useless steam version gave me an idea as I posted.
When I found ffxiv.cfg I just searched for it. It exists in two places and I edited the wrong one.

To whoever finds this in the future, refer to the image.