FFXIV - Stuck at launcher title splash

Hello, this is my first time using Lutris. I’ve been trying to install FFXIV on my Manjaro Linux drive. I have the Steam version. I had tried the stand alone install, and that did get me to the login page… but Square gave me an error, something along the lines of “You don’t have a license to that version”…
Installing from Steam itself leads me into a loop of the launcher simply not running at all. Now, launching the Steam install via Lutris does get me to the launcher window… but it’s just the FFXIV logo over a gray background, and nothing else. (I let it sit like this for a few hours while I went out to eat). I’ve done some looking around and all the solutions I’ve been able to find aren’t really solutions at all, or assume I know more about the system than I really do.

I am having the same issue using the new launcher on standalone (not Steam).

Currently using the old launcher, which works without issues.
Problem is that the old launcher is being phased out in the future.
I have yet to find a solution, but for the time being, you can most likely change the configuration:

  • edit FFXIV_boot.cfg, and change Browser to 1.

Actively trying to figure out how to use the new launcher…

Thanks to some comments on ProtonDB I was actually able to FIND the “FFXIV_boot.cfg” file. Installing on Linux via steam puts it WAYYY back deep.

EDIT: I’m just going through Steam at the moment, so this may not be relivent to “lutris” anymore… but the info might help other people.

Note: For anyone who doesn’t already know… To install non-Linux games via steam you need to go into Steams Settings, go to Steam Play, and check the box to enable Steam Play for all titles. I’m using “Proton Experimental”

  1. Find your “FFXIV_boot.cfg” document… For Manjaro Linux installed via Steam, the path is as follows (be sure to enable “show hidden files” under “View”) .local/share/steam/steamapps/compatdata/39210/pfx/drive_c/users/steamuser/My Documents/My Games/FINAL FANTASY XIV - A Realm Reborn/

  2. Go ahead and open “FFXIV_boot” in your text editor of choice, In that file their are two separate “browser” settings. One is simply “Browser”, close to the top. And, the other is “BrowserType”, close to the bottom. For me, setting “Browser” from 2 to 1 didn’t seem to change anything, was still getting the frozen splash screen and the file would reset the value to 2… Changing “BrowserType” to 1 seems to have done the trick. I changed both at the same time… and both seem to be sticking now. Save and exit… When you do this just try one at a time until it sticks for you as well.

  3. Once you make the changes to the boot config file I did get to log in. A warning about this launcher… “Clicking” the log in button will give you an error and force the launcher to close, but hitting “Enter” to log in will allow you to progress to the game client.
    3.5) I had to disable DX11 in the launchers “Settings” tab… to actually get it to run.

  4. By this point you should be able to log into the launcher, and progress to the “Select Data Center” page… After selecting your data center you may be hit with a black loading screen… Close out the game and go back into .local/share/steam/steamapps/compatdata/39210/pfx/drive_c/users/steamuser/My Documents/My Games/FINAL FANTASY XIV - A Realm Reborn/
    Their will be another config file, generated when you launched the client called “FFXIV.cfg”. Open this one and (use CTRL+F to search) “CutsceneMovieOpening” and change that from a 0 to 1. Save and exit.

That SHOULD be it. I can play the game just fine now. on just slightly lower graphical settings than I’d really like… but I can play. I also notice occasional audio stutter in character creation, but I haven’t noticed it in the game world itself yet.

1 Like