Back to the main site

Feral Gamemode doesn´t work in linux games

Hi , I have a problem , the feral gamemode works only in windows game but not in linux native games , what can I do to fix that problem? thanks (problem fix it)

1 Like

Please define “doesn’t work”. Do you get an error or does it appear to not be used at all?
What did you do to enable it? Did you include gamemoderun(1) in the execution?

1 Like

ok let me explain , when I writter in the terminal
gamemoded -s in linux native games appears
gamemode is inactive
and the same command when I running wine games
appears gamemode is active
is that because I said doesn´t work in game native in linux games

You need to start the game with gamemoderun. This loads the gamemode shared library using LD_PRELOAD.

e.g. $ gamemoderun ./SuperMeatBoy

1 Like

Captura desde 2022-06-21 15-20-32
I have the global configuration like this , is that bad?

So you’re setting this by default in your terminal? Its hard to read the whole thing.
The instructions at GitHub - FeralInteractive/gamemode: Optimise Linux system performance on demand and the gamemoderun script both set the library to just libgamemodeauto.so.0 (though the .so should be linked to .so.0 so it shouldn’t make a difference). On Fedora at least, LD_PRELOAD is set to the library name without the path so the right one will be picked up for 32 or 64-bit executables.
You may want to skim the upstream issues (open and closed) to see if someone else has had this issue.

1 Like

so if I want to active the gamemode in linux I must to writter LD_PRELOAD.

e.g. $ gamemoderun ./gamename ?

Stick gamemoderun at the beginning of the command that launches your game in lutris. The “Executable” field in Game Options.

gamemoderun /path/to/your-game-binary

P.S. I think the LD_PRELOAD method might be deprecated. Either a game is aware of Feral Game Mode, or you should use the gamemoderun wrapper.

Captura desde 2022-06-21 18-59-10

Captura desde 2022-06-21 18-58-37
it said we can´t find the file "gamemoderun/home etc etc

You are missing a space between gamemoderun and the path to the game.

same error happen gamemoderun /home/ricandres bla bla bla

Possibly you might need quotes in this case, because your shell has to interpret the path

gamemoderun “/home/ricandresfriki/GOG Games/Ascendant/start.sh”

Also note that since this is not using the wine interpreter, upper and lower case filenames in the path matter.

but in wine , I’m not have that problem hahaha only in native games linux
I already said that to the top

ok is failed again

Captura desde 2022-06-21 20-21-25

Captura desde 2022-06-21 20-21-56

so… there is not more an ideas?

That’s pretty messed up, it’s trying to execute gamemoderun from the Ascendant directory (it’s probably /usr/bin/gamemoderun). Try this.

For the “Ejecutable” field, try just putting:

gamemoderun

For the “Argumentos” field, try

“/home/recandresfriki/GOG Games/Ascendant/start.sh”

Verify that the path is correct, including upper and lower case characters.

Make sure gamemoderun is actually present. If you have an ancient version of Feral Gamemode it might not be.

Captura desde 2022-06-23 22-09-19