Far Cry 4 - No Sound


I got Far Cry 4 to run under Linux Mint 18.3 / wine staging-3-12-x86_64 / DXVK 0.63 perfectly.

Sound: The intro sound works up until the game-menu is loaded. At this point the game goes silent.
In the installer the Xaudio2_7 is set on override. I tried with and without - no change.

I would be grateful for any hints what I could try.

Thanks :slight_smile:

I’ve got exactly the same problem. What distro/desktop are you using?
For me it’s Opensuse leap 15 with KDE/plasma.

Could you guys please provide wine logs?

Right click the game in your Lutris library > Configure > Runner options > Output debugging info > Enabled
Logs can be found through the menubar > Game > View last game’s log

Also please add Far Cry 4’s exe and set it to winxp in winecfg.

If that still doesn’t work try installing xact through winetricks.

Hi cxf, thank you for your quick reply!
I installed far cry 4 following these instruction:

Here is the log:

Sure feel stupid for not seeing the debug option! :smile:

Update your GPU driver. 390 is stable but old for DXVK. Use 396.51

Hmm, I really like to keep my system as stable as possible and use only supported software as much as possible.
My nvidia driver is 390.77 where the driver of the guy that wrote the tutorial is using 390.48 and has sound working.

Before I uninstall my current driver (from opensuse’s supported repository) and install the unsupported driver from the nvidia site, I would really like to know if this could this difference really have an effect on sound?

I see i forgot to add far cry’4’s exe file in my comment.
But how can i send this file?
Here the file can not be uploaded and public sharing with dropbox doesn’t work anymore :confused:

If you use DXVK 0.54 you should be fine with using the 390 driver. Anything higher might work but is unsupported by DXVK.

No I didn’t mean upload it. Please read what I linked. You add the exe to winecfg and set it to use winxp.

I’ve got DXVK 0.52


OK i’ve got DXVK 0.54 now and still no sound past the intro’s of the game.
Video is a little bit stuttering in the game now.
I’ll in stall the latest nvidia driver and see what that does.
Couldn’t do that before as I needed my system to work.

So now i’ve got NVIDIA driver 396.51 installed and working, but…
With the same settings the game runs as before, but then I tried updating DXVK manually.
First I typed 0.65 (I believe this is the latest version) in the DXVK version field and the game wouldn’t start at all.
Then a few other versions downwards and still no go.
And then I saw this in the instructions for updating DXVK:

Minimum requirements for DXVK 0.60+:
Mesa 18.1.2

Sigh :pensive:

I’ve got Mesa 18.0.2
So all for nothing.
I’m back at NV-driver 3.90.77 now as it is of no use to have the latest driver for me.
Updating Mesa is too much work, maybe even impossible on leap 15.
So that’s the end of that I gues?

OK I found a repository for OpenSUSE leap 15 from where I can update Mesa.
But I’m not going to do that because that is not why I am running OpenSUSE leap 15.
I run that for stability, and that means to avoid having too much latest-and-greatest-repositories enabled.

So again, does this mean it is not possible to get this working on my system?

That’s actually strange & interesting.
As far as I can see I do not have Mesa installed at all, but DXVK 0.63 runs well and flawless with Far Cry 3 (in DX11).
Only with FarCry 4 I seem to have the sound problem.

Mesa version only matters for users with AMD/Intel GPUs.

I’m pretty sure the no audio thing is a known bug with Dolby digital / surround in several Ubisoft games. It has something to do with the brand of audio chip (Realtek) iirc.

The solution, on windows at least, is to switch audio output to stereo.
Or delete a whole bunch of x3daudio & xaudio dlls.
Which I assume just disables dolby audio, and makes the stereo out the default audio source.
But I’m not to sure how to go about altering the audio output in wine…

OK that’s interesting! I wil try to get to know more about that. Thanks trigleph!

“Mesa version only matters for users with AMD/Intel GPUs.”

Ok but lutris didn’t seem to download anything when I typed in newer versions of DXVK with DXVK enabled offcourse like it was shown in the link you provided.
I tried disabeling and then again enable DXVK just to see if lutris then would see what I typed in.
But by watching my network traffic i could see it did not dowload anything, nor did the versions I typed in show up in the list of versions.
Did I do something wrong there?

You can do this in winecfg sound settings.

I had similliar problem with Far Cry Primal. Add Far Cry executable to winecfg and change windows version to xp for the file. It worked for me.