Far Cry 4 Does not work

Hi so this may be a really easy problem but i am super new to lutris and the vulkand dxvk drivers in general so please be patient with my noob-ness but i have tried to install far cry 4 in all sorts of ways and configurations mostly going through the 2 links found here https://lutris.net/games/far-cry-4/ and when i start the game up i usually get one of 2 results being an error pops up in the steam version while it is doing the first time setup saying there has been some error that wont go away unless i kill all wine processes (through the steam installation).
Error message: Expression: [mscorlib recursive resource lookup bug] Description: Infinite recursion during resource lookup within mscorlib. this may be a bug in mscorlib, or potentially in certain extensibility points such as assembly resolve events or CultureInfo names. resource name: Arg-ExternalException

The other result is farcry actually launching but for only about 15 seconds and only to a black screen followed by it crashing (from the Uplay installation).

I am running linux mint 18.3 (which i have recently reinstalled) and have an GeForce GTX 960 128bit currently running the nvidia 415.27 drivers.

So i think it may be poor installation of the dxvk or the vulkan drivers after have followed serveral tutorials including this one: https://github.com/lutris/lutris/wiki/How-to:-DXVK but other games using directx drivers that didnt work before on my linux system such as bioshock 2 remastered work now. so any help i can get will be much apreciated, if there any other info you need just let me know.

also update when starting up from the steam version another box appears right off the bat saying: dll32.exe this application could not be started. you must enable the .NET Frameword from the Windows Features dialog box (from Control Panel, choose Programs, Turn Windows features on or off).)

You’re probably right about it being a dxvk problem.

Try this:
Go to the Nvidia settings program, open Xscreen\OpenGL settings: and disable “Allow flipping”, under the performance heading.

Then try this:
sudo apt install libvulkan1:i386 libvulkan-dev:i386 mesa-vulkan-drivers:i386

If none of that works, maybe try nvidia-driver-418. I was running a GTX 960 a while back, and was experiencing some weirdness with the 415 drivers and below. From memory the 410 drivers actually worked better than the 415 drivers though, but I’d go for the 418 drivers first, and try 410 later if it’s still not working.

I was getting the sneaking suspicion that the Linux drivers for older nVidia cards were being left to rot somewhat.

What version of wine are you running? Also, try downloading the latest tkg version of wine via ‘manage runners’ under the top left menu in the main window. Then set it under runner options tab in your launcher settings.

I have Farcry 4 installed via Steam Proton, which works it seems.
But I haven’t been able to get Farcry 5 to run. I think I saw a youtube video of someone running a pirate version of Farcry 5 in wine, as the DRM was ripped out which allowed it to run I suppose.

yah so i tried your top 2 suggestions and i got the same result. afterwards i tried updating the drivers to 418 but i cant find out how to install them, ive looked up several tutorials and have the drivers ppa in my software sources but when i enter sudo apt install nvidia-driver-418 or sudo apt install nvidia-graphics-drivers-418 like ive found in several tutorial i just get an output saying:

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package nvidia-driver-418

so anyway i loaded up 410 and i got the same result.
i am running wine 4.0 on my system but should that matter if lutris downloads and intsalls other versions of wine like tkg-4.0-x86_64 and the tkg-protonified-4.1-x86_64?

so did you install it directly through steam and not through lutis then? because when i do that i get stuck on uplay because it cant connect to the internet for some reason so i cant log in and it wont let me go on offline mode. but through lutris uplay can connect to the internet.