Far cry 2


see the attached, I am trying to install Far Cry 2 on LINUX but I cannot get any further than whats on the attachment, as it asks for the file ’ FC2serverlauncher.exe’ but that file does not exist ???..…


Looks like an old installer, and it’s losing directory context during the install. Are you using some Lutris install script for that? You might consider manually setting up a Wine prefix (choose “locally installed game” and fill out the fields… skip the game executable for now). After saving your settings, do “Wine configuration” from the menu (that will run winecfg and generate the wine prefix)

Then, use “Run EXE in Wine Prefix” from the Wine menu in Lutris and browse for the installer executable.

Barring that, you can get Far Cry 2 Fortunes Edition on Gog for like $2 right now

That installer (the “backup installers” you download, I don’t mean their Galaxy client) will simply be installing the game from archives and it won’t screw up and prompt for installation source like some dumb ass CDROM from the 90’s.

This is actually one of my favourite games, I’ve had it since the day it came out in 2008 (the original of course). This is now the third time I’ve bought Far Cry 2, but it’s worth a couple of bucks to divorce this from Steam.

Ooof… it’s been several years since I’ve set this up from scratch. For starters, it put my display out of bounds on first run. I had to edit the config file manually to get in to configure the display settings. You may have to kill your X session to get your display back (I flipped to another TTY with CTRL+ALT+F2 and killed it). This file will get created:

/path/to/wineprefix/drive_c/users/yourname/Documents/My Games/Far Cry 2/GamerProfile.xml

If that happens to somebody (it may or may not… it would depend on your display) the easiest thing to do for now is to simply change Fullscreen=“1” to “0”

Then when you launch the game again it will be in a window and you can configure your display settings. If it won’t go full screen after that, quit the game and change Fullscreen=“1” again in the config file.

OK, that may not be applicable to everyone, but this will be. This game hates high framerates, it will act up on high frequency monitors. You don’t have to change the refresh rate to 60 in game, or enable Vsync… use the following launch option (“argument” field) for the game:

-RenderProfile_MaxFps 60

Too high a framerate causes characters to bounce in the air, and may cause positional issues that break progress.

I also hope this doesn’t happen to anyone else, but it’s been years since I started a new game and I had deleted all my saves from the Steam installation.

I ran into an issue where progress wouldn’t trigger. Right near the start of the game, after the lengthy cut scene ride and escape from the town… you get taken in a vehicle and the guy that’s supposed to talk to you just stands there. The game isn’t frozen, he’s standing there moving, the quest trigger just isn’t happening. The mouse does nothing, all I can do is press ESC and quit the game. It’s before any save occurs, and Save is greyed out in the menu at that point. It takes probably 15 minutes to get back there and try again.

I did not find a solution for that. I luckily found an old hard drive where I last played Fortunes Edition in Windows 7 in 2019. I loaded the first game save to get past that point. Things seem fine after that, I played for an hour or so and didn’t hit anything else game breaking. Triggers happening etc.

This is not only on Linux, I read Windows users having this problem and the answer was always “use Multi Fixer” which is a mod. Actually a wrapper for Far Cry 2, a third party launcher type thing.

Hi Grogan,

thank you for your comments, I will go through what you have suggested to see if I can get the game to work.

I noticed on utube that someone had the DVD game files saved as an ISO files ?, will that help to launch the game ??, if so whats the best software to convert the DVD game files contents to an ISO file ?.


It may, if the reason for not being able to extract that file during installation is bad reads. The reason it may help is because a setup program is likely to barf on read-retries, it doesn’t tend to wait for the OS.

I don’t know what to use anymore but I’d think typical burning software should have something in the menu to make an image from a DVD. For example K3B or something.

The problem is, something like a game disc is likely to have some bollocks that foils normal copying or the game will refuse to read the disc if some hidden info is missing.

I used to just use dd to make ISO’s from optical media, but haven’t tried that in many years.

dd if=/dev/sr0 of=filename.iso

(if= input file, of= output file)

I tried your suggestions but it didnt work, Ive tried to install the game through Lutris, Bottles and Wine but it still wont install…. I tried to use a media convertor (Rufus doesnt work on Linux ??) to convert the original files from the DVD to an ISO but it didnt convert the files to an IS0 ??? …
I think the problem lies in getting the ‘setup.exe’ to run ……