Back to the main site

Fallout 4 will only play Intro video WINE-Tkg or WINE GE-Protonified

As the title says, I have somewhat of a weird issue with Fallout 4 running on Lutris: I can only get it to run with versions of WINE that have been deprecated in Lutris’s list of WINE runners (Tkg-4.6 and GE-Protonified-4.10). With any version but these two, the Fallout4 process launches a window, but refuses to play the intro video and just sits there, almost as if it died without closing the window. KDE shows that it’s playing sound, but none is audible.

I don’t mind using Tkg or GE, but I heard that like I said above, they were deprecated, and any new WINE improvements that come out, I won’t be able to use.

How I set up my FO4 prefix

  1. Tell Lutris to use DXVK and ESYNC for the prefix, and set mesa_glthread=true under environment variables

  2. Install Steam normally

  3. Kill all WINE processes, and use winetricks to install FAudio

  4. Set winegstreamer=disabled in winecfg overrides

  5. Configure the FO4 settings, and try to start it up

What I’ve tried:

  • Disabling ESYNC. I heard ESYNC could affect it, but it didn’t work

  • Using the WINE binaries from Proton. The game does function under Proton, but I like Lutris. This didn’t work either, Proton’s WINE makes Steam say it cannot connect to the network.

  • Building my own Tkg WINE. This had the same result as the WINE versions not of the two I listed, but its very possible I didn’t build Tkg right. Their build script for non-arch distros is labeled “experimental”, and there were some strange quirks with this.

  • Removing the override for winegstreamer. Didn’t work.

  • Trying the Lutris 4.16 WINE, without actually using Lutris with a fresh prefix. Same result, so I don’t think its any options in Lutris doing it.

  • Tried the WINE builds from https://github.com/Kron4ek/Wine-Builds/releases, no luck, but I’ll keep those builds in mind. Could be useful for other purposes

If anyone has a fix for this, or a version of WINE that fixes it AND will continue to be updated, I’d love to use it. I’d also be willing to build WINE from scratch.

System Specs:

  • openSUSE Tumbleweed, latest updates, latest Mesa version available from the X11 repo (19.1.7), Kernel 5.2.14

  • MSI B350 Tomahawk

  • Corsair Vengenace DDR4 3000Mhz, 16GB

  • MSI RX 580 Armor 8GB OC

  • Main system partition is on a 500GB WD M.2 SSD, formatted as xfs

  • Fallout 4 is on a 2TB secondary WD drive, formatted as traditional ext4

Log file from the prefix when trying: https://pastebin.com/M7g48fea