Fallout 4 sound bug

Hello,

I’m trying to play Fallout 4 via Lutris using DXVK (latest version) and wine 3.8 staging but I’m running into a sound-related issue.
When I launch the game for the first, like, 2 minutes of gameplay, sound is working properly.
But suddenly it gets stuck on ancient sounds and can’t load newer ones.
For exemple I can hear the radio song which was playing or the dog breathing but if I shoot or talk to an NPC, nothing.
And when the radio song stops, it won’t go on the next one.

I’ve got xact (0 to 9) set to native in wine configuration.

Any idea ?

Thanks for your time !

EDIT : Tried to extract x3daudio1_7 and xaudio2_7 dlls with the cabextract method, putting then in sys32 and setting them to native them in wine configuration but it doesn’t change a thing. :frowning:

Could be another issue not related to wine dlls. I have xact and wine staging 3.8 and my sound is fine. Sound Blaster USB.

Mhmm, I really don’t know what it could be then, do you use DXVK ?

Yes, game is unplayable without it, allot of dx11 games are!

I saw on Fallout 4 Wine appdb that people had the same problem as me but no solution were found :frowning:

You could try the ge3.6 wine version, that is the one I use, I even have the same cabextract xaudio patches set to native and it works very well.

I just tried that and it doesn’t work either, I’m on Solus and my driver version is still 390.48, maybe it’s due to this.

The problem is intermittent. Sometimes the sound is fine, could be related to access something in specific or a certain gun sound file playing. Very hard to put the thumb down on exactly what.

If you get the issue, try closing game and restarting, see how consistent the problem is.

Isn’t there a Wine runner just for Fallout 4? Does that have different results than using 3.8 Staging?

I run Fallout 4 with Wine Staging 3.9, DXVK 0.53 and xaudio2_7 set to native,builtin

No sound issue noticed, no winetricks needed, the game seems to run just fine.
There are some visual glitches but I believe they get fixed when using wine-ge or wine-fallout.

wine-ge and wine-fallout? don’t know what those are. Anyway sound could be specific to USB audio or creative cards, its difficult to know for sure. (oh you mean the options as runners. not sure what patches those are)

This is the one, https://github.com/GloriousEggroll/ge-wine Might give it a go, wonder if it will fix the Fallout4 texture alpha issue for select rust textures (you can spot them on starter vault sparking power-blocks)

1 Like

Riddick the wine version you mentioned is in the runners, it is ge-3.6. I used it with fallout and the xaudio settings to run fallout rather nicely,
I have recently compiled ge (glorious eggroll) patches into 3.9 and it is running beautifully.

Yeah I installed it as a default I think.
However I removed the Gallium9 patches since i have a NVIDIA card. I take it you have a AMD card which is why you don’t see the broken alpha channels on specific Rust textures.

Believe it or not my own custom wine build already had most the GE patches, plus F4SE ones and a couple others.