"Failed to retrieve wine (None) information" installing game

I am unable to install Heaven’s Gate from GOG, getting “Failed to retrieve wine (None) information” error.
I was able to install/run Journey to the Savage Planet from GOG (Also needs wine) without issue.

Running flatpak version under Mint 21.3
Diagnostic output:

Gtk-Message: 14:40:21.911: Failed to load module "xapp-gtk3-module"
2024-02-04 14:40:22,062: Command 'fluidsynth' not found on your system
INFO     2024-02-04 14:40:22,666 [application.do_command_line:479]:Starting Lutris 0.5.16
INFO     2024-02-04 14:40:22,669 [startup.get_drivers:54]:Using NVIDIA drivers 535.154.05 for x86_64
INFO     2024-02-04 14:40:22,669 [startup.get_drivers:58]:GPU: NVIDIA GeForce GTX 1650
INFO     2024-02-04 14:40:22,669 [display.display_gpu_info:78]:GPU: 1002:1636 17AA:3A45 (amdgpu drivers)
INFO     2024-02-04 14:40:22,670 [display.display_gpu_info:78]:GPU: 10DE:1F99 17AA:3A45 (nvidia drivers)
DEBUG    2024-02-04 14:40:23,049 [xrandr._get_vidmodes:16]:Retrieving video modes from XrandR
DEBUG    2024-02-04 14:40:23,164 [lutris.get_missing_game_ids:206]:Checking for missing games
DEBUG    2024-02-04 14:40:58,502 [base.install:327]:Installing 1117322977 from service gog
DEBUG    2024-02-04 14:40:58,503 [http._request:88]:POST https://lutris.net/api/games/service/gog
DEBUG    2024-02-04 14:40:58,891 [api.get_game_installers:311]:Fetching installer https://lutris.net/api/installers/heavens-vault
DEBUG    2024-02-04 14:40:58,891 [http._request:88]:GET https://lutris.net/api/installers/heavens-vault
DEBUG    2024-02-04 14:40:59,175 [application.show_window:392]:Showing window InstallerWindow1117322977
DEBUG    2024-02-04 14:41:00,674 [xrandr._get_vidmodes:16]:Retrieving video modes from XrandR
INFO     2024-02-04 14:41:02,509 [api.get_default_runner_version_info:204]:Getting runner information for wine (version: wine-ge-8-25-x86_64)
DEBUG    2024-02-04 14:41:02,509 [http._request:88]:GET https://lutris.net/api/runners/wine
INFO     2024-02-04 14:41:02,704 [interpreter.get_runners_to_install:257]:Runner <lutris.runners.wine.wine object at 0x7fe3a4ecc590> needs to be installed
DEBUG    2024-02-04 14:41:02,704 [interpreter.install_runner:276]:Installing wine
DEBUG    2024-02-04 14:41:02,705 [runner.install:469]:Installing wine (version=None, callback=<function ScriptInterpreter.install_runner.<locals>.install_more_runners at 0x7fe3b444e520>)
INFO     2024-02-04 14:41:02,705 [api.get_default_runner_version_info:204]:Getting runner information for wine (version: wine-ge-8-25-x86_64)
DEBUG    2024-02-04 14:41:02,705 [http._request:88]:GET https://lutris.net/api/runners/wine
ERROR    2024-02-04 14:41:02,990 [interpreter.install_runner:284]:Failed to retrieve wine (None) information
ERROR    2024-02-04 14:41:02,990 [errors.__init__:18]:Failed to retrieve wine (None) information
ERROR    2024-02-04 14:41:02,990 [exception_backstops.error_wrapper:81]:Error handling idle function: Failed to retrieve wine (None) information
Traceback (most recent call last):
  File "/app/lib/python3.11/site-packages/lutris/installer/interpreter.py", line 278, in install_runner
    runner.install(
  File "/app/lib/python3.11/site-packages/lutris/runners/runner.py", line 481, in install
    raise RunnerInstallationError(_("Failed to retrieve {} ({}) information").format(self.name, version))
lutris.runners.RunnerInstallationError: Failed to retrieve wine (None) information

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/app/lib/python3.11/site-packages/lutris/exception_backstops.py", line 79, in error_wrapper
    return handler(*args, **kwargs)
           ^^^^^^^^^^^^^^^^^^^^^^^^
  File "/app/lib/python3.11/site-packages/lutris/gui/installerwindow.py", line 444, in launch_install
    if not self.interpreter.launch_install(self):
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/app/lib/python3.11/site-packages/lutris/installer/interpreter.py", line 211, in launch_install
    self.install_runners(ui_delegate)
  File "/app/lib/python3.11/site-packages/lutris/installer/interpreter.py", line 265, in install_runners
    self.install_runner(self.runners_to_install.pop(0), ui_delegate)
  File "/app/lib/python3.11/site-packages/lutris/installer/interpreter.py", line 285, in install_runner
    raise ScriptingError(ex.message) from ex
lutris.installer.errors.ScriptingError: Failed to retrieve wine (None) information

I think it is a network issue. Last night I tried to install games and couldn’t do so without the internet(by default). Today I got the same error message as you(with internet connected of course).

1 Like

Update: Tried installing other games from both GOG and Humble Bundle; same issue
Switching wine version from default (wine-ge-8-25-x86_64) to system (8.0.2) is letting me install games
I will update on whether they actually run OK

Heaven’s Gate, at least, seems to run with system wine. A bit jumpy/jittery, but that could just be my computer specs. I’m going to provisionally call this fixed.

An update was released to resolve this.

2 Likes

Set runer wine-ge-8-26 in lutric wine runer settings and the problem solved, apparently the problem is with wine-ge-8-25 raner ?)

No - it is just an issue with some getting the 8-26 downloaded. If you do see this issue, remove the 8-25 and 8-26 wine runners in the lutris wine manager, restart lutris. If 8-26 does not automatically download, then install it using the wine manager in lutris and set it as the default runner in wine runner settings.
Also you can check ~/.config/lutris/runners/wine.yml that you have this entry:

wine:
version: wine-ge-8-26-x86_64

spacing is important so copy/paste if you don’t have this - still need to confirm the 8-26 is installed after this change and restart lutris