Back to the main site

Exit with return code 256 on every game I try to install

Hi, I have searched through the forum and I cant seem to find my exact problem,
EndeavourOS latest with zen kernel
AMD 3950X
Radeon Vii

No matter which game I try to install i get this ERROR

lutris-wrapper: /usr/bin/winetricks
Started initial process 72064 from /usr/bin/winetricks --unattended corefonts
Start monitoring process.
Executing mkdir -p /run/media/kds
------------------------------------------------------
WINEPREFIX INFO:
Drive C: total 4
drwxrwxrwx 1 kds kds  240 May 14 09:46 .
drwxrwxrwx 1 kds kds 4096 May 14 09:46 ..
drwxrwxrwx 1 kds kds  136 May 14 09:46 users
drwxrwxrwx 1 kds kds  256 May 14 09:46 windows

Registry info:
/run/media/kds/500HDD-Hitachi/system.reg:#arch=win64
/run/media/kds/500HDD-Hitachi/user.reg:#arch=win64
------------------------------------------------------
------------------------------------------------------
warning: /home/kds/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/bin/wine cmd.exe /c echo '%AppData%' returned empty string, error message "wine: could not load kernel32.dll, status c0000135" 
------------------------------------------------------
Monitored process exited.
Initial process has exited (return code: 256)
Exit with return code 256

It does not matter where the game is from “GOG/Epic/Origin/Ubisoft/Steam” I get this same error every time.

I’m new to Linux gaming and would love some help to get this up and running

If you need any more info, please let me know how to obtain that info and I will share it.

thank you for your help in advanced!

“/usr/bin/winetricks” <— using system winetricks?

That error tells me that the wine interpreter can’t find the wine prefix. Some variables not being set correctly or something.

A buggered up wine prefix will cause that, and system wine tricks is probably trying to operate on /home/yourname/.wine by default.

I don’t know if you actually have anything in the default ~/.wine location, but try deleting it if you don’t have games or software installed to it. It will get recreated again, “updating wine prefix in /home/yourname/.wine” if you run a system wine component.

You could also try disabling “use system winetricks” in Lutris.

Hi thank you for the help!

I think I figured it out, it was a firejail problem, had to run sudo firecfg --clean
then I could install most of the games, now i just cant get passed that “online anti cheet” something.

and I have to figure out how to get the games to run with use of the GPU-RadeonVII but that is probably a topic of anther post.

after games where installed I could turn back on firecfg.

2 Likes

Installing it on a non-ntfs drive worked for me :wink:

1 Like

how do I delete the ./wine location? Having the same issue

/home/yourname/.wine
Go to your Home and “show hidden files”.