Everquest (p99) No 3d devices found [solved]

Just a warning. I am not well versed with Linux so please bear with me.

I’ve had Lutris running (different machines, different installs) for maybe almost two years. I have not had any problems until last night. Went to bed Lutris working for Everquest (p99) and when I woke up, it stopped working. I thought it was my computer (Debian 11 with Nvidia card) so I tried to fire it up on another computer (Debian 11 with integrated graphics) and no luck, same problem. I fired up my Mac and that install (non Lutris) works. So I am a bit confused as to how something that worked for a long time all of a sudden stopped working. And to top it off, the other computer (Debian 11 integrated graphics) also had the same problem, around the same time, much newer install.

This might not even be a Lutris issue (Wine maybe, I’m not well versed with things) but really love Lutris and would much prefer to get it to work again with Lutris. For now I have to do it the old fashion way via the terminal with the wine command.

I am a new user so I can only post two links but the error message I am getting is basically nothing happening with Lutris and then a “No 3d devices found” window shows up.

Below is the lutris -d

Below is what I copied from the Lutris log

If any more information is needed please let me know. A lot of these stuff is a little over my head so any help would be greatly appreciated. Thank you very much.

1 Like

I’m unfamiliar with EverQuest but I see that there is a complete wiki on the project1999 page on running it under Linux. Their examples use the main wine installation but the principle is the same. Is there a forum dedicated to project1999? Maybe good to also ask the question in that community.


I do not see any reference to 3d devices not being found. The process just seems to exit normally. A return code zero means exit without error.

Hi there and thank you for replying @tfk. I’ve used that wiki in tandem with Lutris. Currently the only thing 99% working is from that wiki you linked.

For me to get the game working I have to fire it up with this command:

wine eqgame.exe patchme 2>/dev/null

While that almost works (I have a problem with mouse look that does was not there with the Lutris installaion), I would prefer to use my old working Lutris.

This is by the way the error I am getting. I think it’s a common Everquest error message. Lutris basically only gets up to this part.

Runtimes were updated yesterday.


Go into Runner Options of the game. Enable Advanced view. Note the versions of those items in the fields and verify that the configured versions actually exist.

Depending on how Lutris is installed, the user data may be in different places

/home/yourname/.local/share/lutris/runtime/ <— for most people including me

/home/yourname/.var/app/net.lutris.Lutris/data/lutris/runtime/ <— Steam Deck, PopOS! (and probably fatpacks)

Only thing I can think of now is the launch command. When you remove the 2>/dev/null part all errors will become visible.

wine eqgame.exe patchme

You could also do something like this to log to a file:

wine eqgame.exe patchme 2> ./errors.log

Maybe it will verify what @Grogan mentioned.

I’d do 2>&1 so initialization messages and errors are together in context.

Thank you so much guys for the replies and thank you Grogan for letting me know about the updates yesterday. The “working 5 hours ago and now it’s not working” was driving me nutters.

dxvk-nvapi v0.6.2
dxvk v2.1
vkd3d version (I dont see “vkd3d-proton”)

Let me fire it up that it dumps the errors on a log file.

vkd3d is the directory name, that’s correct. It’s actually vkd3d-proton (currently v2.8) though.

Forgive me for being very green how do I check if they exist?

Going to /home/myname/.local/share/lutris/runtime/ I have folders for dxvk-nvapi, dxvk, and vkd3d. Some of the contents of these said folders are:

dxvk-nvapi: a versions json file and folders for v0.5.4, v0.6.2
dxvk: a versions json file and folders for v1.10.3, v2.1
vkd3d: a versions json file and folders v2.6, v2.8

As for doing a 2>&1 ./error.log , Do i do that for lutris or for wine? When I do wine the game loads fine. It’s when I load the game through Lutris is when I have the issue. Please advice if I do one or the other or both.

I’ve done a:

lutris 2>&1 ./error.log

No error.log showed up but I am probably just doing the command wrong. If I do Lutris on the terminal this is the logs that shows up:


Thank you again for the help!

Oh man, I’m sorry. I wasn’t thinking, I should have given you a whole command. That won’t work as written (his would have). What I actually did was delay you further.

There are different ways to capture output, try

wine eqgame.exe patchme > ./errors.log 2>&1

No problem. So just to be clear I am not doing this on Lutris but on Wine? I am just double checking since as I mentioned earlier, doing wine loads the game fine. It is when it’s loading on Lutris that I run into problems. I will try the above command and get back to you.

That was just the command you said you were having some success with, and the command tfk gave you. I suggested to capture both stdout and stderr so they’d be in the log file together.

It is ultimately Lutris you want to run this in, so you can try

lutris -d > filename.log 2>&1

Do your business (failure?) exit out, and then find the log in the directory where you typed the command (Your home directory most likely when you open a terminal)

There’s more advanced Wine debug logging in Runner Options of the game. Don’t enable “full” debugging, it’s ridiculous lol. Only enable it temporarily at that. Just try lutris -d first though.

Ok for:

lutris -d > filename.log 2>&1

This is what is in the log file.


The “regular” logging is enabled.

Your wine prefix really shouldn’t be /home/sam/.wine here when using Lutris. (it would be when you ran wine egame.exe and stuff outside of lutris)

I’m not sure I understand what’s going on there, perhaps something going on in the install script. (Is that what you’re doing here?)

In Lutris, go to Configure options of the game. On the Game Options tab, what does it say for the Wine Prefix field? Is it correct? Is it what was there before?

I would try renaming /home/sam/.wine for now in any case though.

After that, In the other game menu to the right of the one with Configure, the Wine menu, go to Wine Configuration. This will run winecfg and update/regenerate the wine prefix.

The game is only 32-bit. I had to install wine32 for it. I think I made a ./wine64 for the other things but ./wine is 32-bit. I included above what I have in that game options. I have always had it as is.

It’s not an install script / I’m not trying to install the game. The game is just on a folder on the desktop named “p99”. As mentioned before, It has always worked until a day or two ago (as you have mentioned, the runtimes were updated).

Hopefully my explanation is not too confusing. Thank you again!

Edit: Launch Titanium.bat is just this:

start eqgame patchme

OK, this is making sense now.

Firstly, it’s defaulting to /home/sam/.wine because that’s the default. The field is left blank.

When you ran the command with your system wine, you updated that. Then you updated it back again when you run it through Lutris again. That’s why it’s not a good idea to do that. It’s fine where it is, as long as you don’t run anything ELSE and let it default to /home/same/.wine with a different wine implementation.

That is an old wine runner you were using.

You just got updated runtimes. That could be why it stopped working.

Firstly, you probably have game state in the /home/sam/.wine directory. Try to salvage that first, it may work just fine being converted back to lutris-fshack-6.21-6

Note that the lutris wine runners have both 64 bit and 32 bit facilities. Your distributor may split system wine pacakges, because distributors are silly that way.

OK, you have two choices here. First, keep using the old lutris-fshack-6.21 that was working before for you. Go to Runner Options and SWITCH those runtimes back to the previous versions that were working for you. They are all preserved. If they were set to the defaults, which they probably were, Lutris would automatically change them when upgraded to the new default runtime versions. You can simply change them back.

If you need to blow away (rename) /home/sam/.wine and try again, find your game data (I’m not familiar with the game, but it’ll be somewhere in the heirarchy of /home/sam/.wine/drive_c/ (and probably in your user dir unless it’s a really old game where it’s stored in the program directory)

Or, try a newer Wine runner in Lutris, in Runner Options of the game. You can even choose “system wine” from that drop list, whatever it is, if you wish, but Lutris runners will be superior to what your distro provides.

You said when you tried it with your system wine, you had keyboard and mouse issues. That could be a focus problem.

Yes, I am sorry I should have mentioned that since starting this thread, I have been going back and forth from Lutris and wine in the terminal. Wine on the terminal was what I have been using the last two days to play cause it still works while I run Lutris to try out the stuff you guys have suggested / to look for info on the Lutris config.

I will be fine if it’s the only thing that works. It is the only game I am playing / currently playing.

Again apologies for being super green, what do you mean by “game state” in the /home/same/.wine directory. How do you salvage that? I am fine with lutris-fshack-6.21-6 as that’s what has been working for me for a very long time. I think I’ve tried a few others but that’s the one that has worked for me. Will it be an issue that the game is located in a folder on the desktop? Should I really move that or it’s fine where it is as long as I point to it?

I am going to try working with the lutris-fshack-6.21 that I’ve had running for a while. When you say “runtimes” are you talking about dxvk-nvapi, dxvk, and vkd3d? When you say change them back, do I go back to those folders and see what version numbers they are and select those older versions on the drop down menus for them in the Lutris Runner options?

I have the game folder just on my desktop. Should I move it there? I’ve had that folder just on my desktop for years and worked fine (until two days ago).

Please let me know. Thank you!

If the game data, I mean your saves and stuff, is in the game folder on your Desktop (you are running the game from there in context of the wine prefix) then that will be unchanged and you’ll lose nothing.

It’s the Wine prefix, /home/sam/.wine that may be the problem.

@Grogan sir, it is working! I would have never found the solution if you guys never helped out!

This was it. I read that and looked into Lutris and the /home/myname/.local/share/runtime directory and compared the versions of the dxvk-nvapi, dxvk, and vkd3d and swapped it back to the older versions (directories) of those three items mentioned and voila! It loaded! I dont know what they do but it worked! Thank you so much!

Is there a way to avoid this from happening in the future? I am still way over my head but at least I learned to output error logs for folks here to see.

Now that you’ve chosen something other than the default version for those fields, Lutris should not touch them again when updating the runtimes.

I’m glad to hear you got it working. I had a pretty solid suspicion it was related to the runtime updates.