Back to the main site

ESO/POE&DXVK: missing Vulkan extensions which are actually supported


#1

Hello,
I’ve installed ESO via Lutris, ran it … and the ground textures were a bit strange (for reference: https://www.youtube.com/watch?v=OY6aPBTKTuU). After reading up on this a bit this seems to be a bug of the native wine DX11 renderer. And sure enough: DXVK_HUD=1 didn’t show the HUD. So I’ve disabled and enabled it again and now DXVK seems to be called, but it crashes quite soon after and creates an eso64_dxgi.log file with the following content:

info: Game: eso64.exe
info: DXVK: v0.93
warn: OpenVR: Failed to locate module
info: Required Vulkan extension VK_KHR_get_physical_device_properties2 not supported
info: Required Vulkan extension VK_KHR_surface not supported
info: Required Vulkan extension VK_KHR_win32_surface not supported

Additionally Lutris tells me every time that Vulkan isn’t supported on my machine, but MTGA runs well with DXVK (including HUD) and vulkaninfo puts out the following: https://pastebin.com/sf1Eax5d (tldr: the win32 extension is missing, but not the other ones).
I’m running this all in an lxd container, which hasn’t troubled me as of now, but might have something to do with this? With Ubuntu 18.04 and all vulkan packages for amd64 and i386 architectures installed, I can’t see where I went wrong. Does anyone have a clue?

Edit: same error log with Path of Exile