Eso and epic

I can install epic in lutris and i can “install” ESO but really it’s just like a template for the installer as the actual installer takes hours to download the game but lets not get ahead of ourselves. After the epic install is finished, that takes only a few minutes it’s supposed to start the launcher (which is really just launching the actual beginning of the install) but it doesn’t launch.

I have lutris and epic and eso installed on another distro install. I use artix linux which is of course arch without that nasty systemd and i use mate desktop and nvidia 550.78-4 which works great for my gtx 1650. I get about 100 fps with optimized settings.

here’s my inxi output

Kernel: 6.8.10-lqx1-1-lqx arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
Desktop: MATE v: 1.28.2 Distro: Artix base: Arch Linux
Type: Desktop Mobo: ASRock model: A520M-HDV serial: UEFI: American
Megatrends LLC. v: P3.30 date: 09/26/2023
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360 charge: 100%
(should be ignored) status: discharging
System RAM: total: 32 GiB available: 31.22 GiB used: 9.08 GiB (29.1%)
Array-1: capacity: 128 GiB slots: 2 modules: 2 EC: None
max-module-size: 64 GiB note: est.
Device-1: Channel-A DIMM 0 type: DDR4 size: 16 GiB speed: 3000 MT/s
Device-2: Channel-B DIMM 0 type: DDR4 size: 16 GiB speed: 3000 MT/s
Info: 6-core model: AMD Ryzen 5 4500 bits: 64 type: MT MCP arch: Zen 2
rev: 1 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
Speed (MHz): avg: 1500 high: 3866 min/max: 400/4208 cores: 1: 3451 2: 3858
3: 400 4: 3636 5: 3866 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400
bogomips: 86238
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Gigabyte driver: nvidia
v: 550.78 arch: Turing bus-ID: 01:00.0
Display: x11 server: v: driver: X: loaded: nvidia
unloaded: modesetting failed: fbdev,nouveau,vesa gpu: nvidia
resolution: 1920x1080~60Hz
API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast platforms:
active: gbm,x11,surfaceless,device inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
API: Vulkan v: 1.3.285 drivers: nvidia,llvmpipe surfaces: xcb,xlib
devices: 2
Device-1: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel
bus-ID: 01:00.1
Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 06:00.1
Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel bus-ID: 06:00.6
API: ALSA v: k6.8.10-lqx1-1-lqx status: kernel-api
Server-1: JACK v: 1.9.22 status: off
Server-2: PipeWire v: 1.0.6 status: off
Server-3: PulseAudio v: 17.0 status: active (root, process)
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel port: e000 bus-ID: 04:00.0
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB bus-ID: 1-2:3
Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Local Storage: total: 2.32 TiB used: 588.04 GiB (24.8%)
ID-1: /dev/nvme0n1 vendor: TeamGroup model: TM8FP6002T size: 1.86 TiB
temp: 37.9 C
ID-2: /dev/sda vendor: Western Digital model: WD BLACK SN770 500GB
size: 465.76 GiB type: USB
ID-1: / size: 97.87 GiB used: 35.73 GiB (36.5%) fs: ext4 dev: /dev/sda2
ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
dev: /dev/sda1
ID-1: swap-1 type: file size: 8 GiB used: 2.2 MiB (0.0%) file: /swapfile
System Temperatures: cpu: 46.8 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 376 Uptime: 2h 49m Init: Dinit
Packages: 1086 Compilers: gcc: 14.1.1 Shell: Sudo v: 1.9.15p5 inxi: 3.3.34

so basically i have artix installed on the one nvme slot inside the machine with a 2 tb drive and lutris runs epic and eso great there.

I also installed artix on an nvme drive that is installed in a usb adapter and connected to a usb 3.2 gen 2 port. that’s the one where i am having the troubles. I have steam installed on this setup and i have no issues running steam or eso on steam but i do have this one epic account i’d like to play from this device also. In both instances i have a seperate root and home partition as well as a separate steam partition in /home/[username]Steamy or the like. And so i had tried a couple of things when this wouldnt run. I tried to symlink to my steam directory hoping that i wouldn’t have to redownload all theose hours long of actual install files. That didn’t help and so i deleted those links. And when that failed to help i tried to copy the spic directories for my installed games from the other nvme to this nvme and that also didnt help and so i deleted all the game directories and started over. Finally i decide to reach out to the forums as it seems the older i get the dumber i get.

so what do i do with this lutris-issue-report.json file?

eso logs

fallout 3 installed and ran just fine. eso will not launch

wow ok so no replies?

ok well something else i tried was installing lutris and then epic and then copying over from my other linux mate install into the new, both the lutris directories i found in the home’s hidden folder at local share lutris and config lutris as well as copting over my epic games directory from one drive to the next. seems like it should work but epic won’t launch from the new linux install


Not everyone has your combo of Epic/ESO so replies will vary, but people are playing it on Linux.
You missed out what version and type of Lutris you are running - flatpak etc, and with or without ULWGL.
The pastebin content doesn’t really cover the game launching, so check output of running lutris -d to rule out anything specific bailing on you during startup.

Since you can launch the store, and other games (including Fallout 3, which uses a launcher) are running, it usually falls to a config/WINE/drivers issue.

Have you tried any environment settings? Disabled gamemoderun/anticheat/other extras? Checked the DX/Vulkan launch options in Lutris? Tried different WINE/Proton? Enabled/checked the Epic games log for launch errors? Is your profile configured with any GLX/NV/PROTON variables for other things?

TBH I’d slow down a bit - reinstalling OS and moving files all over - you’ll only get to a solution by luck, otherwise it’ll just make you more frustrated. Just confirm all the things that should be on 100% stable versions - WINE staging, graphics drivers + vulkan for same, Python - are from sources.

My fallback for debugging is to ditch all the custom config, flatpak etc, running my own choice of WINE/Proton(9.x), then try a clean prefix to install the store/launcher. After that, I trawl options from ProtonDB to see how far I can get it.

Worth a post in the ESO forum to see if anyone else similar to your config got it to run.

Started initial process 3376 from /home/notme/.local/share/lutris/runners/wine/wine-ge-8-26-x86_64/bin/wine /home/notme/Games/epic-games-store/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe -opengl -SkipBuildPatchPrereq -com.epicgames.launcher://apps/4d0ff75b922447649057c237c0bd1545?action=install
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
Initial process has exited (return code: 0)

the thing i find most frustrating is i have the same machine using the same artix mate dinit OS, but installed on a different drive and i have successfully installed it once but not again since.