Error when launching Battlenet through Lutris

Hi. Recieved a weird error today when trying to launch the Bnet client.

The window frame pops up but without contents and then the process hangs and has to be killed. Strange enough it sort of works when I issue “WINEPREFIX=/home/matte/Games/diablo-iii/ wine Games/diablo-iii/drive_c/Program\ Files\ (x86)/\ Launcher.exe”.
Then I see the launcher and the game installer, but when selecting game to install I get to the dialog with the spinning wheel and then I am unable to continue but the process doesn’t hang.
This worked yesterday evening and I haven’t changed my config since. I therefore tried to redownload the game again but with the same results.

Any ideas on this? I am running on Anteragos Linux (arch-based). Other games like Final Fantasy seems to be launching without any issues. Can’t fully test though, since my sub is inactive, but the launcher seems ok.

I sort of fixed it by enabling PBA-mode but when I click install the installation window pops up without any contents.
The Bnet client launch is fine now, though.

Any clue on this?