Back to the main site

Error starting lutris on openSUSE Tumbleweed


#1

Starting Lutris displays the following error and does not start the program

Traceback (most recent call last):
  File "/usr/bin/lutris", line 29, in <module>
    from lutris.gui.application import Application
  File "/usr/lib/python3.6/site-packages/lutris/gui/application.py", line 26, in <module>
    gi.require_version('Gdk', '3.0')
  File "/usr/lib64/python3.6/site-packages/gi/__init__.py", line 134, in require_version
    (namespace, version))
ValueError: Namespace Gdk not available for version 3.0

#2

Looks like you’re missing a Gdk dependency, are our dependencies wrong on the Tumbleweed package?
I haven’t heard complaints from other openSUSE users so it may be a recent change in Tumbleweed? The upgrade to Python 3.6 for example, that was an issue for Arch users where they had to uninstall and reinstall Lutris.


#3

I’m not sure, recently I installed OpenSUSE (it’s also my first contact with this OS).
I installed Lutris using ‘One Click Install’.
I have uninstalled the program and reinstalled it but the problem continues.


#4

if you clone the github repo and launch it from the repo itself (with ./bin/lutris), does it run?


#5

I’ve got the same issue and ./bin/lutris has the same error

I’m using tumbleweed, I’m guessing that a dependency is missing from the build spec but looking at it nothing is obviously missing.

doryx@sam ~/P/lutris> python3 -c "import gi; gi.require_version('Gdk', '3.0')"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python3.6/site-packages/gi/__init__.py", line 134, in require_version
(namespace, version))
ValueError: Namespace Gdk not available for version 3.0

So the issue is with a Gdk3 dep… I’ve had no luck figuring out what’s missing.

I noticed there is an outstanding revision to the spec:

https://build.opensuse.org/request/show/539936

But adding those deps didn’t fix the issue.


#6

I updated my computer yesterday and now Lutris is working.


#7

Signed up to mention that I have the same exact issue. Installed all of the python-related gdk dependencies, can’t get it to work. Really bummed, I wanna play Dark Souls II SOTFS on Linux instead of having to reboot.


#8

Hey so I’m having the same problem post update. I’m on Tumbleweed snapshot 20171203. @97carmine, can you post the output of

zypper search -i GDK

I think there is an issue with the spec file and you might have gotten lucky and have the needed dependency.


#9

Adding the python3-gobject-Gdk dependency to the spec file breaks other OpenSUSE version, I already rejected a patch for this. If someone knows how to patch the spec file so that it works on all SUSE distros, I’ll merge the change, otherwise Tumbleweed will remain broken since it has lower priority than other OpenSUSE versions.


#10

Would you accept a patch then that checks the openSUSE version? There is a macro for that.


#11

Just needed the package typelib-1_0-Gtk-3_0
I’ll submit a request once everything finishes building.


#12

I recently changed Tumbleweed to Leap 42.3 because Tumbleweed stopped working correctly. I do not have much experience with OpenSUSE.

In Leap I did the same installation that I did with Tumbleweed and it also works.

I hope you can help @doryx.

E  | Nombre                         | Resumen                                                           | Tipo   
---+--------------------------------+-------------------------------------------------------------------+--------
i+ | gdk-pixbuf-lang                | Languages for package gdk-pixbuf                                  | paquete
i+ | gdk-pixbuf-loader-libopenraw   | A library to decode digital camera RAW files -- gdk-pixbuf loader | paquete
i+ | gdk-pixbuf-loader-rsvg         | A Library for Rendering SVG Data -- gdk-pixbuf loader             | paquete
i+ | gdk-pixbuf-query-loaders       | An image loading library - Utility to create loaders cache        | paquete
i+ | gdk-pixbuf-query-loaders-32bit | An image loading library - Utility to create loaders cache        | paquete
i+ | libgdk_pixbuf-2_0-0            | An image loading library                                          | paquete
i+ | libgdk_pixbuf-2_0-0-32bit      | An image loading library                                          | paquete
i+ | python-gobject-Gdk             | Python bindings for GObject -- Gdk bindings                       | paquete
i+ | python3-gobject-Gdk            | Python bindings for GObject -- Gdk bindings                       | paquete
i+ | typelib-1_0-GdkPixbuf-2_0      | An image loading library -- Introspection bindings                | paquete

#13

Thank you! Installing typelib-1_0-Gtk-3_0 & python3-gobject-Gdk got Lutris working!


#14

Thanks!
I saw your PR on OBS, if it doesn’t break the other suse builds, I’ll integrate it. Can you send a PR on Github instead? That’s where keep the lutris.spec file. If you don’t have a github account, that’s fine, I can make the change myself.

Update: So the build passed! If you want you can submit the PR, otherwise I’ll just commit the changes. The packages on OBS should now work properly.


#15

That worked for me too in OpenSUSE 15.
Thank you.


#16

Recent updates to Lutris seems to have lost the python3-gobject-Gdk dependency, installing fixed on Tumbleweed.