Back to the main site

Error Rockstart games launcher

Hello, something is happening with the client when it comes to installing it. An error is displayed when opening the client to install it, and suddenly it displays an error and is forced to close.

The photo is of a Reddit user who is happening the same thing, I have it in Spanish.


Me too. I’m linking my issue report from another thread I started yesterday (about KIO error):

Output from “$ lutris -d -i grand-theft-auto-v-rockstar-games-launc.json” until crash:

1 Like

if it is useful on reddit I guess they will give information about it.

having the same issue, any fixes yet?

I solved it, the only thing I did was install another new Linux distribution and when I reinstalled the GTA: SA script I was able to run and play it.
I did it with the most recent version within the repositories with wine in EndeavorOS, wine 6.16.
I’m currently using Arch Linux and I haven’t tried it yet, but if it worked for me before, now I think it’s the same.

Now in Arch Linux the same error seems to appear. The weird thing is that in EndeavorOS it worked, I only install wine in version 6.16.
And in Arch I get the same error.

By chance I have found an unbelievable easy fix for me:
In the file structure of wine. in the user folder, Rockstar is storing some info for the game, launcher and Social Club.

I noticed, that the folder in Windows is named “My Documents”, whereas in my Wineprefix it is named “Documents”.

I simply renamed the folder to “My Documents” and the game started with no further issues