Error: Installation exits, return code 256


Trying to get my games on a new computer, and I keep getting an error 256 when I attempt to install them. I’ve looked around and tried deleting config folders, installing a different version of Wine and using that, completely removing Lutris and trying again, etc, but I keep getting the same error, around the same point in the process.

It seems like it’s trying to pull a file from Github called “andale32.exe”, but the request keeps timing out. I put the link into Firefox and it loaded in about 30 seconds. It also warns about using a x64 wine prefix instead of a x32, but I don’t see how that’d have bearing on the request timing out. I’m not sure what to do about this one. I’ve pasted a screenshot of the installation’s command box work below.

Any help is appreciated, thanks!

Well, it is clear from the errors that it is not even able to reach DNS to do lookups for github, before it even does the HTTPS call, so lack of Internet access is your main issue.

Check whether you have a secure sandbox, apparmor, or something similar blocking Lutris (or python) going to the internet.

Try starting “lutris -d” from a command prompt and see if it complains about similar lack of internet access when checking for updates. Then you know you have an OS/environment problem.

Edit: Also check you are running Lutris v0.5.11 or newer - there was a known exit 256 issue back then.

Followed the tip, used the “lutris -d” command and found I was using 5.9.2, so I uninstalled with the “apt remove --purge” command, and updated to the 5.14 package I found on their GitHub. Ran the command again and found a warning about session registration, pasted here.

I don’t have any program like AppArmor on my computer, but I turned off the settings firewall just in case. Problem still appears. I don’t think it’s Lutris not having access to the internet generally, since it’s able to download the Wargaming installer without an error message.

Would there be a way to lengthen the timer for that request to GitHub to try and bypass the problem?

The registration warning you can ignore, that’s just Gtk

The exact point it was failing at is not lutris itself, but it calling winetricks, then that trying to download a font that the installer says it needs.

Try running the get from the command line and you should get a font file appear: -
…because that’s literally all winetricks is doing.
If it times out doing that, its still an OS or environment issue. Maybe using an HTTPS proxy (set in environment or something you are using at the perimeter) or something else like your wget is a custom version or horribly out of date?

Other than that, you could try downloading and using the latest version of winetricks, then check the lutris global setting to use system winetricks.

The only other workarounds are hacks, really. Far more worthwhile finding out why that call is getting blocked, because it is likely going to affect all installers.

I’ll go the system winetricks route. I followed that call before all of this and was able to get it downloaded through my browser in about 30 seconds. As for the software, it’s freshly updated Mint 21.2, nothing from outside the software channels besides video games.

It is affecting other programs! I use Lutris for access to World of Tanks etc, Battlefield 1 on EA Origin, and GTA-V through the Epic Games store. Everything else I’ve tried through Lutris has the same issue. The flatpaks for Discord and Heroic (the Epic Games launcher) also have timeout issues, and seem to be unable to connect to the internet, but not Steam or RetroArch. Haven’t tested other software with this computer cause it’s dedicated for gaming, but it’s definitely troubling that other software isn’t able to connect either. So far no leads.

Update: Since then I had a completely fresh install of Mint 21.2 Edge, installed Wine and Winetricks, but Lutris still quits with a 256 error from a connection timeout from trying to get a different component: I managed to get World of Tanks working somewhat correctly on Wine alone, so I’m going to give that a second pass.