Epic: high CPU usage

Hi! I’m running Epic through Lutris with the Nvidia 450 drivers. For some reason, when running Epic, the output of grep MHz /proc/cpuinfo is maxed out: all CPUs are running at 4200MHz. Note that this is before running any game (or after closing all games).

When I run a game (I’ve tried Abzu and A Short Hike), the CPU usage (in top) of the game goes up to 350% or more and the CPU temperature obviously shoots up too. nvidia-smi shows that the Epic launcher and the games are using the GPU, with GPU usage around 40%.

Any ideas what is going wrong?


  • CPU: i5-10300H
  • GPU: Nvidia 1660Ti
  • RAM: 8GB
  • OS: Ubuntu 20.04
  • Kernel 5.9


These are the first lines when running lutris -d

2020-10-22 22:48:05,528: Getting full game list from MAME...
2020-10-22 22:48:05,528: MAME XML generation launched in the background, not returning anything this time
2020-10-22 22:48:05,529: MAME isn't installed, can't retrieve systems list.
INFO     2020-10-22 22:48:05,598 [application.do_command_line:275]:Running Lutris
INFO     2020-10-22 22:48:05,598 [startup.check_driver:54]:Using NVIDIA drivers 450.80.02 for x86_64
INFO     2020-10-22 22:48:05,598 [startup.check_driver:58]:GPU: GeForce GTX 1660 Ti
INFO     2020-10-22 22:48:05,598 [startup.check_driver:73]:GPU: 10DE:2191 1025:143E using nvidia drivers
INFO     2020-10-22 22:48:05,598 [startup.check_driver:73]:GPU: 8086:9BC4 1025:143D using i915 drivers

The logs from A Short Hike also show the game as using the Nvidia GPU:

info:  D3D11CoreCreateDevice: Probing D3D_FEATURE_LEVEL_11_1
info:  D3D11CoreCreateDevice: Using feature level D3D_FEATURE_LEVEL_11_1
info:  Device properties:
info:    Device name:     : GeForce GTX 1660 Ti
info:    Driver version   : 450.80.2