Epic Games wont start: unhandled page fault

Hello. I’ve been using lutris and the epic games store to play some games on ubuntu for some time now, but today, out of nowhere, epic games is refusing to open fully. The window would pop up for a brief period but then the thing would crash with

wine: Unhandled page fault on read access to 0000000000000000 at address 00000000084D587B (thread 0051), starting debugger...

Here’s the full output of lutris -d: https://paste.ubuntu.com/p/tgYDVSvpJb/

And here is the file generated by lutris --submit-issue: https://paste.ubuntu.com/p/c7QPYZmSV3/

Same problem here.
Yesterday it was working properly but not today.

Epic games launcher stopped working for me today in a similar manner. I was able to launch it without crashing by changing the wine version to 5.21 (default) from 5.7 . Still no idea why it crashed on 5.7 after epic games updated itself

had the same problem, however 5.21 didnt exist for me, but 6.0 rc1 does work, too

however, gta v runs like nuts with 6.0 and someone reported bad performance with WOW Classic, too. so it might introduce new problems…

Yep! Thanks, this workaround seems to be working. I switched the runner from the lutris wine 5.7 one to my system 5.0 one and disabled esync.

Any idea where to find another wine version? Im having the same problem

I’m having the same problem too. But it seems than only the 6.0 rc1 version works for me. Not 5.0 or 5.2. I also have to disable Esync.
But GTA V is unplayable with 6.0 rc1. Any workaround?

None that I am aware of. GTA V for me is unplayable due to me pressing any key on my keyboard the game freezes up completely. You too? Really sucks because the new island is in 3 days

to play GTA V this worked for me:

performance feels a bit worse than 5.7.x but it’s playable


Can confirm this works, even me pressing any keys it has stopped lagging

This. Thank you for clear instructions. Kinda annoying that Lutris doesn’t list all possible versions. I just spent time compiling lutris-6.0-rc1 with an age-old keyboard patch and it was a workaround that worked, but… A mess, still.

It does. In Lutris go to the menu, click Manage Runners, then scroll to WINE, then click Manage version, tick the boxes you want.