Back to the main site

Epic Games with invisible form

I’m trying to use Epic Games but part of the first screen (with login, etc) is invisible. When I mouse over it, is perceptive that the buttons are there, but its impossible to continue like that.

I will be so glad If u help me to solve this!
I’m on Pop!_OS 20.04, Wine and Lutris installed from Pop!_Shop

[System]
OS:              Pop!_OS 20.04 focal
Arch:            x86_64
Kernel:          5.8.0-050800-lowlatency
Desktop:         pop:GNOME
Display Server:  x11

[CPU]
Vendor:          GenuineIntel
Model:           Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
Physical cores:  4
Logical cores:   4

[Memory]
RAM:             7.7 GB
Swap:            4.0 GB

[Graphics]
Vendor:          nouveau
OpenGL Renderer: NVA5
OpenGL Version:  3.3 (Compatibility Profile) Mesa 21.0.0
OpenGL Core:     3.3 (Core Profile) Mesa 21.0.0
OpenGL ES:       OpenGL ES 3.0 Mesa 21.0.0
Vulkan:          Supported

I had to disable “Use discrete graphics” of general “System options”, DXVK of “Runner options” and add a “MESA_GL_VERSION_OVERRIDE” key with the value of 9.9 to the environment variables (System options) in order to solve another problems and get here.

Logs don’t say me anything

Running /home/nathan/.local/share/lutris/runners/wine/lutris-6.1-3-x86_64/bin/wine /home/nathan/Games/epic-games-store/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe -opengl -SkipBuildPatchPrereq
Initial process has started with pid 129146
Start monitoring process.
esync: up and running.
Initial process has exited (return code: 0)
Monitored process exited.
All monitored processes have exited.
Exit with returncode 0
Running /home/nathan/.local/share/lutris/runners/wine/lutris-6.1-3-x86_64/bin/wine /home/nathan/Games/epic-games-store/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe -opengl -SkipBuildPatchPrereq
Initial process has started with pid 129767
Start monitoring process.
esync: up and running.
Initial process has exited (return code: 0)

Thanks in advance.

Try with enable DXVK. If DXVK disable i too get black screen

1 Like

I don’t believe this was the problem kkkk
love u. strangely it was not working with this option on, but now… it seems alright
thxs